Jump to content
CaddyInfo Cadillac Forum

Radio issue after new battery 96 eldorado


Recommended Posts

Recently replaced my battery and noticed that my radios volume and dsp won't work after about 10 seconds of turning it on, it will show that I am turning it up/down on the screen but no change in volume, if i want to turn it back up or down then i need to turn it off then back on and it'll work for again about 10 seconds. I checked the front fuses under the hood (all good) and also checked for a good battery connection. Any suggestions

Link to comment
Share on other sites


You can try resetting all the modules. Disconnect one battery cable and hold it against the other one for 30 seconds or more, then reconnect the battery.

You should run the OBD codes before doing this, then drive the car, including using the volume up/down and the dsp switch, and run the codes again after you part but before you turn off the key. Look for codes that are CURRENT or that are the same both times.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

I know the battery connections seem good & tight, but for this type odd behavior I recommend take the cable connections off the battery, if there are multiple positive cables connected in the stack take the stack apart, clean everything, and put it all back together.

Bruce

2016 Cadillac ATS-V gray/black

Follow me on: Twitter Instagram Youtube

Link to comment
Share on other sites

Is the security light flashing on the radio?

Theftloc did not start on Cadillac til 1998. It would say theftloc on the display panel in white (like the Bose symbol)

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

It clears all " memory" by clearing/discharging any module that may have a transient/residual voltage to keep a memory setting "alive".

You can do the same thing to your computer by disconnecting the power cord and pushing the power button on. If you happen to catch it, you can even see the power indicator light come on for a minute second.

At least that's the way us old guys understand it.

Rockfangd, thanks - did I mention I was old :);)

THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Link to comment
Share on other sites

Is the security light flashing on the radio?

Theftloc did not start on Cadillac til 1998. It would say theftloc on the display panel in white (like the Bose symbol)

The '96 Fleetwoods had the Theftlock radios.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

Is the security light flashing on the radio?

Theftloc did not start on Cadillac til 1998. It would say theftloc on the display panel in white (like the Bose symbol)

The '96 Fleetwoods had the Theftlock radios.

They do. I forgot to specify the E/K platform.

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...