Jump to content
CaddyInfo Cadillac Forum

Parking lamps stays on, no matter what..1994 STS

Recommended Posts

Dear all Cadillac freaks.

It´s been awhile since Ive been on here but last time I got great help..

Anyway, My name is Olle (pronounces Ollie) and Im over in here in Sweden, EU.

The car is a real nice 1994 Seville STS, No codes and runs great, it my daily driver (for as long as I can keep it running).

I do have the 2 "phonebooks" of a service manual for it , and the car is an Export Model. From Switzerland.

So, quite a bit about the schematics/wiring seems different compared with the US models, unfortunately..

Electrial problem:  I´m somewhat versed in electronics, but by no means a "meistro."


Now, for my dilemma, I can not get the Parking Lamps to shut off, started about a week ago..Had to disconnect the battery. I have

the car in a garage where I can work and do extensive diagnostics myself, that is good.

What I see with the Battery connected is:

Parking lamps are on all around, and, also the instrument cluster is lit up and can be dimmed with the knob.

The headlight switch is also lit up (the bulb inside).

This phenomenon has sporadically been going on for about a month, but it would actually shut the light off itself after a few minutes , althoug

I did find it weird, since I had not touched/tinkered with the Twilight Sentinel or anything like that. it is and always has been in the "OFF" position.

But, as I said, last week it would not shut off at all, and it happeded when I hooked up a battery charger to it. hmm..

Car was sitting with everything off, but suddenly turned on the Parking lamps on by itself! if this was related to the battery charger or not..I don´t know.


1. I have pulled out/removed the headlamp switch housing and disconnected the connectors in the back, No change, Park lights still on.

2. Ive removed the fuses for the parking light in the trunk: D13 D11, No change, Park lights still on.

3. Ive pulled out (I think all the Relays) in the Micro Relays Center 1,2 and 3 in the trunk with the battery connected and the Parking lights still stays on!

4. pulled out the connectors for all "computers" in the trunk (except for the Body Control Unit)..same thing, Park- lights still on.

5, cleaned all the fuse blocks, no change, obviously.


Possibly, 12V is leaking (a short?) someplace feeding the parking lamp cercuit?  Do you have any ideas?


Here are a few questions:

Someboby mentioned potential problems with a busted protective "Zener Diode" on the harness .

Looking at the scematics in the Service Manual 8A-201-58 , there is supposedly a "DIODE PACK" by the left  rear seat chassis sill/panel , I did open the -

whole thing up, exposing all the cables/wires (yes, many and all the colors of Benetton!) , but can not find any diodes or a diode-pack there?

see image, Do you guys know if there really are any  "Zeners" on the harness anywhere at all?


Any ideas, thoughts or comments are welcome!


Cheers, Olle






Link to comment
Share on other sites

Hmm. You have me scratching my head.

This may be a long shot but maybe try unplugging the instrument cluster and see if they turn off. 

I am not sure if your 94 uses the Cluster as the main for all of the modules.

I will have to think some more on this one.


Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Hello, and thanks for your replys.

To my knowledge there is/has not had any remote start or alarms.


The car used to belong to my late dads´who actually was a contributing member of this forum years ago.

(Car has had the head bolts fixed (by my father, a semi professional mechanic) and runs great for an old car, )

I went thru it last night again, and have some additional info:

Like said, pulling out the relay "B" in Relay block 2 in trunk changes nothing, I can measure 11V on one of the pins? is that in order no?

Measuring  the Fuse D13 on fuse block in trunk (park lamps) there is 11 Volts there too?..despite light being off and no key in ignition.


(I measured the Ohm´s on the Twi sentinel foto resistor (just because I could) and it responds to light..seems to be working and has been changed before it looks like.


I did a search for the same problem but broadend it to include other GM vehicles, I read some which gave me other ideas to try:

1. seems many people had faulty Towbar electrical (trailer light) connectors, but there is no such connector ever wired on my car..

2. Bad ground, someone mentioned wiring an extra ground cable direcly from battery to some other (rearward) ground point to try and

possibly boost the ground connection to the chassis to see if that potentially could help a bad ground? if..that seems to be the case.

3. Engine compartment fuse block, try to start pulling other fuses, one at the time and see if there is a short in the block feeding

current to the parking lights. , Also remove/lift up Fuse block - take it apart, looking for arching/short..but, in honesty, I don´t think thats the culprit.


I also opened up the Harness again (like open heart surgery) in the rear (by rear seat LH panel) where the Diodes are supposed to be..nothing?...According to the "mega" Service Manual -the "Diode Pack" should be just there..but is not..strange..Could it be that my car, export model/harness does not come with protective Diodes ? who knows..


Anyway, Thanks for looking and taking your time, Have a good one.






Link to comment
Share on other sites


Dear all,

I think I solved it today!  Unplugged an electronics box in the trunk...no more parking light running (by themselfs), Win!


I found a box in the trunk that, after some research, appeared to be an Aftermarket thing..but was mounted

professionally amongst the other GM Original controllers etc..but had some funky wiring to it that perhaps looked

a bit suspicious..hehe.

I removed the screws and inspected it, was written in italian on the back of it,  hmmm, weird..

Opened it up and I see a bunch of relays..and it has an antenna, OK, so, it´s some kinda remote Keyless entry radio- receiver I guess?

Brand: "Synkra".  We/I havent had the Keyless operating for 7-8 years I think..just using the keys old school to open the doors, no

remote "clicker" present since I can´t remember....


So, I unplugged it and no more Parking lamps, took the car out and all seems to be working as per usual. no problems

and lights are operating normally, like they should!

I assume one of the relays is stuck on the PCB..see image.

I´ll get back here if the problem comes back, but most like it will not, it works great now.


Thanks alot!




Link to comment
Share on other sites


Even I would not have guessed back there. Excellent diagnostics. Never heard of that brand and have dealt with many.

Please share a few pics. 

I love our Sevilles. They are actually rare, and you said yours is a export? Parts are very difficult to find for them. 


Nice, clean, luxury= fine automobile

Link to comment
Share on other sites


Yes, There are´nt many on the road here either anymore, most have gone to the crusher due to the Headbolts fiasco..

My dad actuyally made a decent extra buck in the 2010s fixing the headbolts issue for other Northstar owners.(in his extensive home shop/garage-

 where he did a complete Timesert job for $1800 including parts vs GM shops asking upwards of 5k..so..we sometimes worked together)

I love the STS Seville´s too, (and they are cheap) this one has a newer (replacement) lower milage engine (inc timesert job) and a replacement automatic in it.

Car is originally from Switzerland (you know, bordering to italy, hence, the italian electronics box in the trunk compartmnet I reckon.?)

No salt on the roads in southern europe, so, no rust to speak of on this car..it has had an overspray/paintjob to it in 2005 sometime, where they applied a 3 coat

Pearl thing to it, a color that originally appeard a little later in the 90s from what I heard.

Ive also heard ideas that if you keep/kept changing the coolant regularly on these Northstar motors from the get go, they will not corrode down the

headbolts threads? (back in the day)..but I really don´t know if that is the reason? is it an old wifes tale?  You guys know? What really makes the threads go bad over time?


Perhaps buying another car for the future:

I have a lead on another Cadillac I´m somewhat tempted to buy.. a 1994 Eldorado TC which is in great shape, and has had the timeset kit job done

to it a few years back.. And here´s what makes that car special: it has a 1999 Drivetrain in it, installed by my dad, He actually managed to keep the 99 intake etc

and did some modifications to EGR ports and intake and all that jazz,  a lot of rewiring of the more modern engine, to get it to run correctly in a 1994..So-

It bet it´s very unique and from what I hear, it runs fatastic too!.. Cool mod.  The Story: The owner had gotten hold of a complete low milage 99 drivetrain but

his car was a 94 Eldorado with headbolt leak issue..so, they made an attempt to get the 99 engine into the 94, and it eventually worked! no codes..


It´s a shame about the headbolts issue for these cars, it it wasnt for that, the Northstar is one fantastic engine..I love it.

As long as the bolts been fixed, these cars are just magnificent.





Link to comment
Share on other sites

It looks like @Logan nailed it.

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

Most if not all export cars had no keyless remotes. Some odd broadcast frequency conflict between the cars and some export countries laws. FCC type stuff. Easier and cheaper to sell the cars with no remotes than to try to comply with all the European laws. Pretty sure latter cars had them after those issues were cleared up. 

There is actually a RPO code for remote delete....T2R. 

Some info here..


Another dirty little secret. The German export Seville/ STS had non functioning 'dummy' third brake lights. German lighting laws on that one.....some of those cars ended up in Sweden.  

My next suggestion was going to be about the damaged wire harness in the trunk. The driver side trunk hinge can crush the harness bundle when closed and cause phantom working and non working circuits. 

It was easy to get a picture of a damaged harness this week.....this owner had the trunk liner removed. Wow....1992 STS....28 year old car...he's had it since new.






Link to comment
Share on other sites

Thanks alot Logan. great info.🙂

I just checked into the old forum thread "Remote Keyless"...lots of info there..wow..

All I can say is, yes, most likely my car did not come with Keyless from factory. and, it might be Aftermarket dealer -

installed back in the nineties..or later installed by somebody in Germany? (car ended up in Sweden in 2007 though. now with me)


After all,  I can see why a customer demanded that a/any luxury car should come with a keyless central locking system.

Personally, No big deal for me no keyless.

I got the car for 1200 USD a few years ago, so, I wasnt gonna make a fuss about the car (my STS) not having Keyless.

I do have the lining in the trunk still intact, and the Harness looks good from my perspective..nothing getting kinked or twisted.

Why would anybody remove the lining in the trunk anyway? 🙄😊


And Yes, There seems alot was "special" for the Export model.. quite different harness it seems..from the look of it.


To clarify: The reason it took me so long to figure out that this Keyless box in the trunk was at fault, was because I didnt know the car even had a Keyless-

electronics wired in, albeit, not utilized anymore. (since I have never seen the actual remote/clicker)

Im just using "pure" keys for the car.

Thanks for all the support guys!



Link to comment
Share on other sites

I am not sure what that module is. 

How many plugs and wires went to it? Might help to narrow its purpose


Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

The 1992 STS owner.....was just passing thru on a round trip. 

The third brake light was not working at all (which is a red flag to check the harness at the hinge). 

Told him on the phone his mechanic needed to check that part of the harness. His mechanic could find no problem. 

They removed the trunk and lid liners in order to save time when we looked at it. So yeah....a bit unusual to have the liners out.....hence us being able to take a nice clear picture of what a damaged harness looks like. Common '92-97 Seville / STS problem. 

Went right to it....harness conduit had electrical tape around it....a dead give away......opened it up and sure enough....broken blue wire for the third lamp. Other wires in the bundle had been previously repaired before too. 

Picture was taken after the tape and plastic conduit had been removed from the harness. 

Link to comment
Share on other sites

Thanks for that heads up.

I will have to check my Seville.

I suppose that could have been some kind of keyless entry module...


Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...