Jump to content
CaddyInfo Cadillac Forum

2004 Deville won't start.


PAUL T

Recommended Posts

My 2004 Deville has been running rough lately, then last week we got gas at a local Sams Club. I should have went somewhere else when I saw the bags on some of the pumps. I ended up filling it up, then we stopped a few miles down the road for snacks and when we got back on the road and was sitting at a light it just died. My wife tried to start it a few times to no avail. Then after a few minutes she tried it again and it started but it was running rough. She kept the rpm's up until it smoothed out and we headed home. I suspected bad gas then. It ran ok for about a week and I filled it up again at another station, it ran good a few more days then died on me at home. I managed to keep it running enough to back it into the driveway. I went out this morning and it would not start. I put some dry gas in it and tried to start it again but no luck. It would fire occasionally but no start. The current codes are: P0171, P0174, P0897. The history codes are P0300, P0410, P0463, P0748, P01106, P0520, P2507. Where do I start?

Link to comment
Share on other sites


I kinda thought the same thing when my 2001 did it. 

Just after filing up.....rough running....SES lamp...was it bad gas?

Anyway...171 and 174. Both banks running lean codes. 

Could be failed rubber coupler under the intake. Cadillac only part....about $20. Intake has to come off the replace. It will look ok from above....it will be rotted out on the bottom. Bad ones cause 171 and 174 all the time. 

 

Link to comment
Share on other sites

I have already changed that a few years back. Could it be bad again?  I also changed the elbow on the right side of the intake earlier. I might have to check the intake bolts in case of vacuum leak. 

Link to comment
Share on other sites

  1. dont forget to check your fuel pressure.

your pump may be weak. also could be burnt plug to it. Seen nearly every one with the plug burnt

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

It is not even firing now. My wife says she hears the pump kick on. I will have to see if I can find my fuel pressure guage. I also need to check and possibly clean the Throttle body out. Same codes.

 

Link to comment
Share on other sites

  • 2 weeks later...

Changed the spark plugs and broke a few coil plugs on rear harness. Bought a new wiring harness from dealer and paid $128 for what I was told was 2 harnesses, only got one and the plugs wouldn't fit the existing coils and they wouldn't take it back. So I bought the Delphi rear coil module which consists of 4 new coils and new harness for $114 from Rockauto. Gonna try to put it on in 20 degree weather tonight. I still need to drain the gas tank and refill with known good gas but the weather here is not helping. Can't get it started now to check for vacuum leak. Could it be crank sensors?

 

Edited by PAUL T
added more info
Link to comment
Share on other sites

  • 2 weeks later...

Is there a code for a bad starter? While cranking the starter it will hit but not start, then it rakes like cranking the starter with the engine running. I replaced spark plugs on the front and back and coils on the back. The starter has been acting up for a couple of months.

Link to comment
Share on other sites

there is no code for a bad starter. sounds like it has a bad bendix.

It is spinning but not popping out by the sounds of it

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

I reread the codes and noticed a P0120 code which is a TPS code. So I ordered the TPS Sensor and installed it and that took care of the hard starting. The car started and ran like a champ and the SES light disappeared. No codes for now. Thanks to Logan and rockfangd that posted, I couldn’t have found the problem without you all. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...