Jump to content
CaddyInfo Cadillac Forum

Webasto moonroof part 97 Seville


Recommended Posts

Hi all. I guess this is the reason why my moonroof is not working properly. 1997 Cadillac Seville, Webasto Dealer add on unit

th_20170422_154746_1492890977788_zpsxyyj

No idea exactly how it is attached and where it is supposed to be positioned. Looks to be a timing gear that tells the moonroof where to stop

Update. Hers is the picture of where gear goes and where it was, but I dont know what position it goes on. I see it just clips on. No idea why it came off though.

th_20170422_173307_1492897048030_zpsqfjp

th_20170422_173314_1492897047572_zpsl5qp

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites


It looks like there is an e-ring groove in the shaft but I don't see an e-ring to retain the green part.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

I think they are still in the sunroof business.....have you tried contacting them? 

https://www.webasto.com/us/markets-products/car/

You also might be able to find the service manual for it online. Do you have the model #? Here is the 300 series..

http://www.donmar.com/tech/h300l-svcmanual.pdf

 

Link to comment
Share on other sites

4 hours ago, KHE said:

It looks like there is an e-ring groove in the shaft but I don't see an e-ring to retain the green part.

it clicks into place in the hole but not sure where it is supposed to be positioned

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

  • 2 weeks later...

Ok so the moonroof was a easy fix. All I had to do was reattach the green disc in the right place.

It now works properly.

I still have some confusion though with this unit.

It has 3 wires going to it

RED constant Hot

Black ground

White/red Ignition

It does not work on the RAP circuit like the OEM one, but according to the manual it is supposed to close when the key is turned off.

It never has. Not sure why. But it is functioning when thee key is on so that is a huge step

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

  • 1 month later...

Update. 

that green timing part fell off again. 

I have no idea why it would fall back off as it is tight to pull it back off when it is reattached.

Only other thing I can think of to do is put a drop of oil where it spins and hope for the best.

I didnt know it had fallen off until I kept hearing the motor clicking. Grr

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...