Jump to content

1998 Deville 4.6l base. won't start with new fuel pump, new fuel filter and good pressure to fuel rail


Recommended Posts

I had an issue about a week ago where the car stuttered and stalled. I have replaced the fuel pump and fuel filter. I have what appears to be good pressure at the test port. It just turns over and won't start, Injector fuses are good I can see voltage across them. Where do I go from here? I only have today to solve, must work tomorrow.

Link to post
Share on other sites

Do you have any DTCs (Diagnostic trouble codes) showing?  Better to diagnose than to just throw parts at it.

If I had to guess though it's the fuel pressure regulator.

Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Link to post
Share on other sites

Ok this may sound stupid but I see ways you checked for fuel, but have you verified spark?

Does fuel pump prime when key is cycled on? Do not confuse it with the air ride compressor. Fuel pump comes on first, then shortly after the compressor.

Is the security light staying on? any message on dash?

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to post
Share on other sites

I have not verified spark, to do so I should pull plug wire and using a screwdriver lay close to frame point and attempt to start car, watch for spark during start attempt?

All 8 spark plugs were replaced today, I'm surprised the car ran with the look of them. recommended for this engine is .050 inch, the old ones were at .080 or more.

Link to post
Share on other sites

Does it chug? Or anything other than just spin over

Does the fuel pump prime when the key is cycled on?

I would try a spritz of starter fluid into the throttle body and see if it fires. 

You can pull the vacuum line off the top of the regulator. (driver side) rear of engine at rail). I am not leaning toward the regulator yet though without more info

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to post
Share on other sites

I would have suggested pulling codes but with a drained battery it can cause random codes. Charge or replace battery, clear codes, retry

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...