Jump to content
CaddyInfo Cadillac Forum

check engine light blinking


MN Mark

Recommended Posts

I'm new to the forum and was hoping to get a little info on what maybe wrong with my car. I have a 2001 cadillac dhs now i've had it a little over a year and it ran good but a few months ago i was driving and the car start to sputtering like it didnt have any gas well i go get gas right away. After i get the gas the car is still idleing hard well i pop the hood and see a small wire cracked it was cold and just broke.well i find out that its the vac line and i got it fixed and now my check engine lights still keeps blinking when ever my car gets to 20 mph when it goes to 19 stops blinking as soon as 20 blinking again. i do need to change a few thing on the car tune up, coolant, new tires maybe tire rods. well any info will be helpful so thank you and have a good day and no since the blinking i haven't been driving the car.(still runs good just idle harder than usual

Link to comment
Share on other sites


Sounds like a miss from a P0300 misfire code, go to the bottom of my post and follow the directions on how to check codes for your year and model and post any codes here

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

A misfire will set a DTC and illuminate the SES light. A blinking SES light means severe misfire detected.

No need for Autozone. You can pull the DTC's yourself from the DIC.

Link to comment
Share on other sites

Thank you very much i didnt know that you could do that. I plan on fixing it myself, and it didn't start idleing hard until i was stuck in the snow up here and was putting it in drive and reverse and so on and on and when i put it in drive from reverse and the engine was still reved up too 2000 rpms and it shifted hard and then started running ruff like it is now. I really like this cadillac and i'm not selling this one but i was hoping if you might know how bad the misfire might be. it still sounds good after it warms up and is still in park but after i put it in drive it idles a little harder but still runs good. and thank you for any and all advice you givin.

Link to comment
Share on other sites

There is likely a problem with the #2 spark plug or the ignition pack that connects to all four plugs on the front of the engine.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...