Jump to content
CaddyInfo Cadillac Forum

Traction Control broken in my Sixty Special


Recommended Posts

So My 1993 Sixty Special has no traction at all, and this is pretty troubling during the winter. The SSS light is also on, and I've heard these two are related, but this wasn't always the case. This is among many other problems including a Power Drain, but I want to focus on getting my traction control back up and running, because I will get stuck in my driveway when half an inch of snow falls...

Link to comment
Share on other sites


It sounds like you have multiple electrical problems, which could affect each other. If you can read the OBD I trouble codes, that would be a good start.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

Simultaneously press and hold the OFF and WARMER buttons on the climate control panel with the ignition on. The codes will display on either the fuel data center or the climate control panel. Write down the codes and post back. When you see .7.0, the system is awaiting additional input. You can either turn the ignition off or press AUTO to exit diagnostics.

The SSS light is indicating there is a problem with the electronic suspension which most likely has disabled the traction control.

You shouldn't need traction control for 1/2" of snow - maybe you need new tires?

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

Thanks, KHE; I don't have a 1993 FSM or direct experience.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...