Jump to content
CaddyInfo Cadillac Forum

4.9 bog


stever

Recommended Posts

my car is driving me nuts when it gets warm usely after 8-9 min it will fall on its face if you try to hit the gas hard. so im stuck driving like a old man babying the gas all the way. good for mpg but sucks when trying to merg. ive put in a new fuel fillter and did a tune up wires plugs cap rotor and coil pack cheking the basics since it was time and i just had a cat and muffler with dual pipes put on since the cat was pulged all of this has helped the way the motor runs and sounds but it still bogs like a old carburater. ive read about cheking the egr so i disconected it to see if stoping it from opening would stop the problem that didnt work just left me with a check engine lite so i reconected it and cleard the code im starting to belive its the fuel pump screwing with me what do u guys think? oh yeh it never shows a code. thanks in advance steve

Link to comment
Share on other sites


That's exactly how my '92 4.9 acted when the fuel pump was going. Ran fine until I put my foot in it. Then acted like a carb with a bad accelerator pump. Also ran fine at WOT til it warmed up. Put a fuel pressure guage on it and see what happens when you throttle up. If the fuel pressure falls, it's time for a new fuel pump. :(

Link to comment
Share on other sites

Good luck; sometimes it is the ECM -- they rap on it to see if that causes erratic symptoms in some cases. The 4.9L is a good solid motor overall, so hopefully you can track down the problem.

Bruce

2016 Cadillac ATS-V gray/black

Follow me on: Twitter Instagram Youtube

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...