Jump to content
CaddyInfo Cadillac Forum

Backfiring/Popping 96 Deville


jndnaps

Recommended Posts

Hey folks, long time no post. Question, on my 96 Deville, I kinda feel a little miss in it. If I'm sitting at a light it'll run smooth and then all of a sudden kinda stutter and then clear up. Also, if I hit the gas hard it'll backfire/pop. That's the only way I can describe it. At first I thought bad coil pack, but it's not like I remember a bad coil pack would do. I can't see the onboard computer codes because the dash lights went out again. I used a Actron code reader and the only code I get is a P1634. Any ideas? Thanks! 

Edited by jndnaps

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

  • jndnaps changed the title to Backfiring/Popping 96 Deville

Hello. 

Is that code current? if cleared does it return?

Before I go farther  I would like to confirm

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

5 hours ago, rockfangd said:

Hello. 

Is that code current? if cleared does it return?

Before I go farther  I would like to confirm

Yes and it won't clear. 

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

I would suggest pulling the black cover off the electrical center at the driver side strut tower. Inspect it well for corrosion. Inspect the fuse blocks and plugs for corrosion.

Sounds almost like the ICM is losing power or ground, likely power. The fuses are under there

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

On 3/17/2021 at 9:17 PM, rockfangd said:

I would suggest pulling the black cover off the electrical center at the driver side strut tower. Inspect it well for corrosion. Inspect the fuse blocks and plugs for corrosion.

Sounds almost like the ICM is losing power or ground, likely power. The fuses are under there

OK, so the code did clear. I did it wrong the first time. I cleared it days ago and the problem is still there. It was real bad a couple days ago and then last night it was fine. It's coming and going. I rechecked the codes and still no codes coming up. The popping sounds like it's coming from the engine. Maybe Throttle body area. Car would also stutter real bad when you really give it gas. Right now it's in the shop and it's not doing it for them now either. But that's how it usually goes.. 

Edited by jndnaps

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

Thats no surprise.

Did you happen to inspect the Electrical panel?

What about the ICM and its coils. Maybe a critter chewed one of the wires to the ICM... Coils themselves are very robust. (originals) Aftermarket... All bets off

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

On 3/22/2021 at 9:49 PM, rockfangd said:

Thats no surprise.

Did you happen to inspect the Electrical panel?

What about the ICM and its coils. Maybe a critter chewed one of the wires to the ICM... Coils themselves are very robust. (originals) Aftermarket... All bets off

The shop didn't find the problem. Intermittent problem and never any codes. I picked up a new coil and was gonna swap them out one by one to see if that would work. Went on YouTube and found a video of a guy testing them and I went out and did what he did in the video and found one coil was weak. I swapped it out and the car runs fine now. But this car has a lot of problems. The steering wheel controls for the radio and A/C don't work. At times the radio will change stations on it's own and the volume would either go all the way down or blasting all on it's own. Same with the A/C, temp would go from 60 to 90 and the fan would go from high to low. I'm assuming it has something to do with the steering wheel controls. Now today the radio quit working all together. I don't see any problems in the wiring anywhere that I can see. One of these days I believe the car is gonna burn.. Just way too many electrical problems. 

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

I still drool over that car. Still my favorite year.

You very likely have corrosion, pinched wiring, or a faulty plug connection (open pin, cracked pin, etc...)

Define radio is dead please? Oe radio?

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

1 hour ago, rockfangd said:

I still drool over that car. Still my favorite year.

You very likely have corrosion, pinched wiring, or a faulty plug connection (open pin, cracked pin, etc...)

Define radio is dead please? Oe radio?

Well it doesn't look as good as it does in the pics anymore. No more Vogue tires and no center caps on the wheels and the rear passenger door is still caved in from the drunk driver that hit me back in 2017. It's still a good looking car though. Pretty sure it's days are numbered though. LOL.. So the wife said the radio didn't work at all, but I just think that the volume was down all the way. I was wondering what would happen if I just unplug the steering wheel controls all together? But I guess I can't do that because of the stupid airbag.. LOL  

The Vogues I got from Cardio-Doc years ago. He told me they were brand new even after I asked him what the dates were on the tires. Then when I get them they were already over 2 years old. He lied and then said that I can return them on my dime if not happy.. Buyer beware with that guy.. POS!! 

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

I have had my 97 D'elegance for about 5 years now, although very nice there is a no doubt change in quality compared to my 96.

And maybe it is just me but the 97-99 looks worse without the Landau. Body looks like it is missing something.

Let me look at the datalink schematic and see what I can find that correlates with the HVAC and radio. I would think the IPC#1

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

On 3/27/2021 at 5:29 PM, rockfangd said:

I have had my 97 D'elegance for about 5 years now, although very nice there is a no doubt change in quality compared to my 96.

And maybe it is just me but the 97-99 looks worse without the Landau. Body looks like it is missing something.

Let me look at the datalink schematic and see what I can find that correlates with the HVAC and radio. I would think the IPC#1

Yeah the 94-96 are definitely better looking. I love how the rear tire is partially covered. Inside is better looking too in my opinion. I have an AM/FM/CD stereo from I think a 93 or 95 Seville. Too bad I couldn't just slap that in. It worked great back when I took it out. 

1355177301_Caddy2.thumb.jpg.40dfc05e0861db8b3e74deec4f75cc76.jpg

 

Link to comment
Share on other sites

See I like the 96 specifically for 2 main reasons.

I hate the 92-95 interior but love the body. (interior was boxy and awkward)

I am not a fan of the 97+ body but love the interior. (Cheapness really starts to show in body)

96 nails all of the above. Great body, engine, interior, etc...

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...