Jump to content
CaddyInfo Cadillac Forum

ice cold air on drivers side sahara heat on the passenger


Recommended Posts

Hi everyone Long time no write! quick question and hopefully quick fix. my 97 DeVille is blowing Ice cold air on the drivers side and Sahara heat on the passenger. I had been getting a B1341 code and I cleared it once. This showed up about three weeks ago and went to history cleared, and it hasn't returned. So can anyone tell me what I should be looking for while trying to figure this out. The searches I have found lead me to a clogged heater core (but alot of the posts Ranger states that a clogged core is usually reverse of what I got)

Any idears?

Thank you all!!!!

Edited by SeanMannino

Sean M.

1997 Cadillac DeVille

Link to comment
Share on other sites


Either low on freon or blend door actuator. If its super hot air then maybe even control panel malfunction telling one side to produce heat. Maybe hook some gauges up to see if your a/c is ok. Start there.

* 1966 Deville Convertible

* 2007 Escalade ESV Black on Black

* 1996 Fleetwood Brougham Black on Black V4P -Gone
* 1983 Coupe Deville Street/Show Lowrider -Gone

* 1970 Calais 4dr Hardtop GONE
* 2000 Deville DTS - Silver with Black Leather and SE grille GONE
* 1999 Seville STS - Pearl Red GONE

Link to comment
Share on other sites

Hi everyone Long time no write! quick question and hopefully quick fix. my 97 DeVille is blowing Ice cold air on the drivers side and Sahara heat on the passenger. I had been getting a B1341 code and I cleared it once. This showed up about three weeks ago and went to history cleared, and it hasn't returned. So can anyone tell me what I should be looking for while trying to figure this out. The searches I have found lead me to a clogged heater core (but alot of the posts Ranger states that a clogged core is usually reverse of what I got)

Any idears?

Thank you all!!!!

Dude,

Definately the actuator. Take the glove box out and you will see a small metal shaft coming from the air box that is threaded on the end and connected to a little white plastic arm by a clip that it snaps into. This is what contols the blend door for the passenger side. The actuator is the little black control box that controls the little white plastic arm. Either replace the actuator or until you replace it you can rig it to blow cold by uncliping the metal shaft from the white clip and sliding the shaft from right to left into the air box until it stops and the securing it ( i.e. zip ties)this will close of the heat on the passenger side until you get a replacement actuator. Same thing happened to me on vacation on my 97 SLS. I temporarely fixed it until I could get back home, order and replace it.

Link to comment
Share on other sites

Okay everyone thank you all for the input. I went ahead and started taking the glove box out and got a call and had to button everything up so I could go and take care of the business I was called out on. I decided to turn the heater on (91 today and I decide to run the heat LOL) well I ran it all the way up to 90 let it run for a few minutes at 90 while idling at a stop light and then slowly ran it back to 60. What ever was going on is now no longer going on as the passenger side got cold within a few seconds and we are now running an icee machine from the back seat! lol anyhow, I will get the actuator for when it decides that it is going to permanently take a trip on me so I can make a quick swap.

I thank you all for your input and expertise!

Sean M.

1997 Cadillac DeVille

Link to comment
Share on other sites

It might have just been a stuck air mix door and exercising it (running it to 90 and back down) freed it up. My '97 Deville used to stick like that, though no where near as bad, just a little temperature imbalance. When it did, running the temp up to max and back down again always cured it.

Link to comment
Share on other sites

  • 2 weeks later...

I've been having the same issue lately with my actuator. There is a little access panel in the glove box and I just bump the actuator a little bit and it starts working again. I will eventually replace it, but for now this works fine. :P

-Dusty-

2006 Cadillac DTS Glacier Gold Tri-Coat with 175,000 miles

1993 Cadillac Sixty Special Gold Mist with 185,000 miles

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...