Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

Hello first off I'd like to tell you I'am new to this form and thanks for haveing me on.

I'am working on a 1997 SLS

1. dome lights inop

2.dash lights flashing ( security,air bag,maynot restart,all of the possable failures

3. radio comes on with key out and door closed and the antenna goes up

4. when running the ac will blow warm when the radio display goes black and some times come back on

5. blower motor blows after the car is off

6. unable to read codes with cheap scanner

Well I have read alot of the forums and tried a alot of things first I tried un pluging the igintion switch thinking it was not shutting off compleatly

re the radio staying on left it over night with the thought of replaceing the switch. the next morning I got to the car thinking I found the problem

and as soon as I opened the door the rado came on ( note on radio it makes noise sometimes like static like its not powered up all the way with the key off)

so I am back on the trail . so now I am thinking its a ground problem so I pulled the sill plates and back seat diconected the battery and wire brushed every ground and bolt I could find hoping I had just lost ground to some modual .this didn't fix the problem eather but it seems to start and run better. Next I try pulling the radio ie maybe the radio is bad although it playes fine when the car powers up some times .I pull the radio and start

the car and every thing is working like its should I can even get the display to give diag codes using the off and warm button on heater control I wrote down 46 before I ran out of paper.

I thought I had found the problem the dome lights worked the dash display was working no warning lights the ac was cold. so I got more paper

to read the codes there must have been 100 + codes and the car acted up agin I can't get back in to read the codes the dash is flashing.

So now I am looking for a break in the data bus line and any direction anyone can give I don,t know what to test or what not to unplug

I do know that the cheap scanner wont read if the bus line is gone so I can use it to see if its working. I saw some were the list of code on this site

I can't remember where . I'd like to look up the codes I have

Any help would great

I know its darkest before dawn

THANKS D

GOD BLESS

Link to comment
Share on other sites


Hello first off I'd like to tell you I'am new to this form and thanks for haveing me on.

I'am working on a 1997 SLS

1. dome lights inop

2.dash lights flashing ( security,air bag,maynot restart,all of the possable failures

3. radio comes on with key out and door closed and the antenna goes up

4. when running the ac will blow warm when the radio display goes black and some times come back on

5. blower motor blows after the car is off

6. unable to read codes with cheap scanner

Well I have read alot of the forums and tried a alot of things first I tried un pluging the igintion switch thinking it was not shutting off compleatly

re the radio staying on left it over night with the thought of replaceing the switch. the next morning I got to the car thinking I found the problem

and as soon as I opened the door the rado came on ( note on radio it makes noise sometimes like static like its not powered up all the way with the key off)

so I am back on the trail . so now I am thinking its a ground problem so I pulled the sill plates and back seat diconected the battery and wire brushed every ground and bolt I could find hoping I had just lost ground to some modual .this didn't fix the problem eather but it seems to start and run better. Next I try pulling the radio ie maybe the radio is bad although it playes fine when the car powers up some times .I pull the radio and start

the car and every thing is working like its should I can even get the display to give diag codes using the off and warm button on heater control I wrote down 46 before I ran out of paper.

I thought I had found the problem the dome lights worked the dash display was working no warning lights the ac was cold. so I got more paper

to read the codes there must have been 100 + codes and the car acted up agin I can't get back in to read the codes the dash is flashing.

So now I am looking for a break in the data bus line and any direction anyone can give I don,t know what to test or what not to unplug

I do know that the cheap scanner wont read if the bus line is gone so I can use it to see if its working. I saw some were the list of code on this site

I can't remember where . I'd like to look up the codes I have

Any help would great

I know its darkest before dawn

THANKS D

GOD BLESS

Link to comment
Share on other sites

Quick update on this car I was able to get the codes agin after moving the car. like the last post the car has a lot of codes mostly history

and a few active ones.

P 1626 C

RSST 1227 C

IPCB 2419 C

I have a lot of codes for loss of communications all over the car one reacurinng one is U1300 class 2 short to ground which would explain the

loss of data all over.

this car has had front struts replaced with aftermarket ones if that means anything .

the hard part is to find the short to ground in the data bus as it comes and goes with movement and temp it seems.

can some tell me what pin and color is the class 2 data wire and at what module

Thanks D

Link to comment
Share on other sites

I do not recognize those codes, do you have the descriptions?

The Helms FSM has great schematics in it,very usefullfor troubleshooting intermittant problems. I highly recommend you purchase one if you don't have one already

OldFart

Link to comment
Share on other sites

Quick update on this car I was able to get the codes agin after moving the car. like the last post the car has a lot of codes mostly history

and a few active ones.

P 1626 C

RSST 1227 C

IPCB 2419 C

I have a lot of codes for loss of communications all over the car one reacurinng one is U1300 class 2 short to ground which would explain the

loss of data all over.

this car has had front struts replaced with aftermarket ones if that means anything .

the hard part is to find the short to ground in the data bus as it comes and goes with movement and temp it seems.

can some tell me what pin and color is the class 2 data wire and at what module

Thanks D

This is as close to your codes as i could find...

P1626 - Theft Deterrent Fuel Enable Signal Not Received

C1227 - Left Rear Excessive Wheel Speed Variation

B2419 - Twilight Photocell Circuit Problem

Posted Image
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...