Jump to content
CaddyInfo Cadillac Forum

2001 STS issues starting and staying charged


Recommended Posts

OK heres a brief history...a couple of weeks ago I started my car in the morning as usual and it would not stay running unless I held the gas pedal down. After it is driven for a couple of minutes it will not stall...note...it will do this randomly sometimes starting with no issue at all. 2 nights ago I was driving and my power steering went out...then it would come back for a few seconds again randomly.Next day no problem with the steering at all.

Yesterday I was driving it, I stopped for a red light the battery light, ABS and Traction Control Lights all came on...a message was displayed "service charging system" not the first time I have seen this message it comes on for a few seconds and then goes off. All my gauges dropped as if the car was off and yet it was still running...I drove off and battery voltage increased wipers were slow and window was going crazy as I was trying to roll it up...drove i for 35 minutes no issues. I stopped at a gas station went in, came out and car would not start...all lights, seat, radio were working but all I got were clicks...shut everything off tried to start same response. Walked home, my husband went to check it out and it started right up and didnt even stall. Brought it home parked it and it was dead again. Today it started up he drove it for about 10 minutes came home turned it off and then tried immediately to start and it wouldn't start. Tonight I went out battery was at 11.5 while not started and 15.1 once started.

We have replaced the serpentine belt and battery in the last year, the alternator tests fine, battery has good amps and doesn't really go dead...we have tried fuel injector cleaner thinking we got bad gas initially...what could it be? Tomorrow we will check out the venting, grounds and battery posts. Any help would be appreciated!!

Link to comment
Share on other sites


Verbal descriptions often fail to paint the entire picture.

We need the Diagnostic Trouble Codes (DTC) to tell "the rest of the story". Here is how you can display your DTC (have a Big Chief tablet and a Crayola handy);

http://www.caddyinfo.com/readingcodes.html

Post the codes for us and someone will provide guidance.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Small problem I ran the codes and I didn't know what I was doing and cleared them before writing them down...there were a million of them; some saying History, some saying current, will they appear again after it is driven or starts again?

Link to comment
Share on other sites

Verbal descriptions often fail to paint the entire picture.

We need the Diagnostic Trouble Codes (DTC) to tell "the rest of the story". Here is how you can display your DTC (have a Big Chief tablet and a Crayola handy);

http://www.caddyinfo.com/readingcodes.html

Post the codes for us and someone will provide guidance.

Small problem I ran the codes and I didn't know what I was doing and cleared them before writing them down...there were a million of them; some saying History, some saying current, will they appear again after it is driven or starts again?

Link to comment
Share on other sites

Sounds like a battery problem. While the codes may help (they may also be set because of the battery problem). An internal 'short' or 'open' in the battery may cause the symptoms you describe. Heat/vibration could have caused the battery to loose its ability to function (as part of the circuit). By all means check your codes again (they may tell a different story) but keep in mind, ramdom electrical problems frequently are attributed to a bad battery and or connections. Your charging voltage of 15 volts pretty much eliminates the alternator and the 11.5 points to the battery loosing a cell.

Chuck

'17 XT5, '04 Bravada........but still lusting for that '69 Z-28

Link to comment
Share on other sites

My battery lost a cell a month ago.It was throwing random codes and driving me nuts,but it started every time. finally it went out completely and jumped it 3 times in a day to get a battery.After that all was well.I know autozone can read the codes. Advance auto parts cleared the codes on my other car once i fixed the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...