Jump to content
CaddyInfo Cadillac Forum

97 STS. TCS & ABS lights on.


Recommended Posts

I pulled the motor to replace a head gasket. That all went well, but the traction control and ABS lights are on now. The car is taking off in 2nd gear as well. I don't think the speed sensative megansteer is working either. The car runs great but those are the problems i'm having. Here are the current codes i have;

IPC U1255 Class 2 Communication Malfunction (Serial Data Line Malfunction)

RSS C1783 ICCS2 DL Left Output Short Circuit to GND

RSS C1785 ICCS2 DL Right Output Short Circuit to GND

The battery was weak so that was replaced. I pulled, cleaned and replaced all the under hood fuses and maxi fuses. Checked all ground wires. Re-seated the connectors for the ABS brake module. I have no idea what to do next?

Where can i buy elbow grease? I don't want to use any of mine!

Link to comment
Share on other sites


Did you leave a wheel speed sensor unplugged or damage the suspension position sensors at the front of the subframe? I'd need to look up the specific codes in the manual.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

Did you leave a wheel speed sensor unplugged or damage the suspension position sensors at the front of the subframe? I'd need to look up the specific codes in the manual.

I double checked all the wheel speed sensors, plug and unpluged them several times. Did i damage the suspension position sensor? I don't know. Confused. If thats where all the brake lines go to we're on the same page. If so, it came out easy. It was never dropped or anyting. The large connector that plugs/clips into it came out nice. I reseated that a few times as well. The connections looked clean. I can bolt/unbolt and build anything. I never went to school for a technician so troubleshooting is a little tough. I just need some direction. I'd bring it to the dealer if my wife and i were not both layed off of work.

Where can i buy elbow grease? I don't want to use any of mine!

Link to comment
Share on other sites

I'll look in my shop manual this evening and see what I can find on the RSS codes. The RSS codes are what's causing the traction control and ABS lights to come on.

The box where all the brake lines enter is the EBTCM (Electronic Brake and Traction Control Module) The plug has a cam lock install the wire harness onto the EBTCM and a "gernade pin" to keep the cam lock engaged. You might check to make sure this connector is fully seated and there are not any bent pins on the connector.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

  • 2 weeks later...

Still no luck on the problems. Just wondering; the brake pedal just does not feel right. It takes a lot of foot pressure to stop the car. The pedal is tight, but if i push it hard, i can bottom it out. Pumping the pedal upon a stop does not correct. it does not sink if sitting at a stop light though. Is it possible there is air in the system yet? If there was, would this set the codes i'm having? I did bleed the system with a mighty-vac starting with the farthest wheel first. Then after each wheel i manually bleed them with a person pressing the pedal in the car. Just a thought. I hate to sell, this car but at this point i'm ready to just dump it.

Where can i buy elbow grease? I don't want to use any of mine!

Link to comment
Share on other sites

Anyone wanna buy a cadi? Has 160k, body is spotless, rust free West Virginia car we had shipped to Minnesota. It's never sen snow. The body is flawless. Interior is nice, new GM ac compressor, just timeserted the motor and replaced all major things along the way. Here's the issue, ABS and traction light came on after the timesert job. I missed something stupid along the way. thinking the harnes that wraps over the tranny has a broken wire. the harness was stiff and i;ll bet it cracked while i moved it. i do not have the time to look into it, i'm starting a business in Jan of 2011 and i need this garage spot! The motor runs sweet, good power, no smoke and a bonus no anti-freeze use. I don't have the time or room to fix, it's time to sell the car. I just put new BF goodrich performance tires on this about 300 miles ago, they were like $600. Tinted glass, 6 disc CD changer. CVould go on and on. My price is firm, but i know it's worth $2,500. I just put over $1,000 of work into it. Located in Central Minnesota. May trade for a snowmobile/ATV of near value. $2,500.. 320-267-7548

Edited by mudweiser

Where can i buy elbow grease? I don't want to use any of mine!

Link to comment
Share on other sites

  • 3 months later...

I got some time to look into it. It turned out to be a corrosive wire from the under hood relay center. It was in the large black main plug next to the drivers strut tower. I cleaned up the connection and it solved all my codes. At last, a Caddi with no codes!

Where can i buy elbow grease? I don't want to use any of mine!

Link to comment
Share on other sites

I like to tell you that Im proud of you for solving your problem. You did not complain,whine or blame others and you worked very hard. I have a 97sls great car. Please dont lose your positive attitude Mike

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...