Jump to content
CaddyInfo Cadillac Forum

Radio not working '93 De Ville


Recommended Posts

I have read many posts but not sure what to think. We have a standard cassette/stereo the radio worked for about 30 seconds now just the clock. I have checked and replaced fuses. Still no go. I have power to all items listed for fuse #11 except to the radio and the antenna. I have read it needs an unlock code. Then I read it does NOT need an unlock code. So confusing. I have been trying to remove it in order to get the info to get an unlock code. I need help to get the radio working. Can anyone help me?

Link to comment
Share on other sites


There is no Theftlock code needed for that radio - Theftlock came out in the 1996 model year. You have power to everything on the "radio" circuit except for the radio? If that's the case, it sounds like there is a broken power wire that feeds the radio.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...