Jump to content
CaddyInfo Cadillac Forum

96 deville dash cluster???


Recommended Posts

I am a noob hear. My gage cluster is giving me trouble. I have a 96 deville and the dash will go on and off and start reading off service messages while driving down the road. Also the AC will only work when it wants to. I think I have a bad ground or a bad connection on the cluster. The car runs and starts normal. When the dash works it seems normal but when it goes out and comes back on it resets all the trip info and heater controls. What is the best way to pull the cluster and not break anything else? Thanks

Link to comment
Share on other sites


Before you try removing the cluster, remove all 3 battery terminals and inspect and thoroughly clean them. then see if the problem persists

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Before you try removing the cluster, remove all 3 battery terminals and inspect and thoroughly clean them. then see if the problem persists

Thanks for the tip. I was able to fix it by pulling fuses and relays and cleaning with contact cleaner.

Link to comment
Share on other sites

very good. I am guessing in the underhood electrical panel?

The electrical systems are very picky on good connections. so much signals being sent

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...