Jump to content
CaddyInfo Cadillac Forum

BLOG: jcobz28's Blog - Hating this car more than ever right now!

Recommended Posts

So the drama continues. I got the SECOND EBTCM that was sent to me installed in the car this weekend, and it STILL doesn't work. Now the guy who sold it to me off of ebay went through the trouble of even trying it out in his STS before he sent it to me and said it definitely works. Plus he's a board member here, so I trust him that it is a working part. But darn it, it sure as hell won't work in my car. I've ran through ALL the FSM diagnostics and wiring diagrams and troubleshooting trees, and it all comes down to the bottom of the page saying "bad ebtcm, replace module". I have NO serial communication with the EBTCM. All the diagnostics I've run show proper system voltage in the harness, good grounds, no shorts to ground, voltage, or opens. The 800 circuit (serial data) modulates around 6v as supposed to and has no shorts to voltage, ground, or opens. I am stumped, and just fed up. I decided to put the module in and just sell the darn car as is, and just accepting the depreciation of selling it that way. I'm done dealing with this issue.

So, I get the module bolted in. Bleed the brake lines. Go to start it up, and CRACK THE MOTHER F'IN STUPID-AZZ KEY OFF IN THE IGNITION LOCK!!!! Just broke in half like it was made of plastic. Just cranking the motor normal. No weird pressure on it or anything. Just SNAP from the key, and OH HELL NO out of my mouth.

Now I gotta take apart the steering column. Fun fun fun. NOT! I ordered a lock cylinder from rock auto which just came yesterday, and a uncut #15 key from ebay. In the mean time, the car won't start. The ignition will turn, but the theft deterrant is active. I tried putting the 1/2 of the key I DO have in the lock so it can read the pellet resistor, but no luck. The system won't "reset" the timeout clock on the anti-theft until it senses the key has been removed from the ignition, which I can't because half of it is stuck too deep in there. Even tried pulling the battery to get it to reset, but that didn't work either. The antitheft must have some sort of writable memory or something...

Read Full Article and/or Comment/Reply


2023 Cadillac CT4-V Blackwing

Follow me on: Twitter Instagram Youtube

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...