Jump to content
CaddyInfo Cadillac Forum

Low Coolant Message


slayer129978

Recommended Posts

I got the message Low coolant level Last week or maybe the week before, So i put some more in until it was at the proper level, Then today I got the message again, Put more in. Then when i got done with school (mechanics school no less) i got check oil level, I have no coolant leaks that i know of. Sometimes when im driving around i can smell coolant i havent seen any coolant puddles or anything like that. I also have like mud kind of looking stuff in the coolant take, Do you guys think these could be signs of a blown HG.

006.jpg007.jpg
Link to comment
Share on other sites


The "mud" you see is cooling system supplement aka sealant tabs. If you smell coolant you have an external leak somewhere. Dried Dex leaves a chalky white residue. Surge tanks and side tanks as well as water pump cover gaskets are known culprits.

Link to comment
Share on other sites

The "mud" you see is cooling system supplement aka sealant tabs. If you smell coolant you have an external leak somewhere. Dried Dex leaves a chalky white residue. Surge tanks and side tanks as well as water pump cover gaskets are known culprits.

yea ive seen some white residue around so once i have a place i can use a lift ill check the back lines someone told me the lines behind the engine are know to rot out.

006.jpg007.jpg
Link to comment
Share on other sites

The "mud" you see is cooling system supplement aka sealant tabs. If you smell coolant you have an external leak somewhere. Dried Dex leaves a chalky white residue. Surge tanks and side tanks as well as water pump cover gaskets are known culprits.

yea ive seen some white residue around so once i have a place i can use a lift ill check the back lines someone told me the lines behind the engine are know to rot out.

Now i have a bad leak i can see coolant gathering on that plastic skid plate thing on the bottem of car and im not sure where its coming from it looks like it may be coming from the front of the engine somewhere one of my friends said it might be coming from the the water pump but im not sure. any ideas?

006.jpg007.jpg
Link to comment
Share on other sites

Might be coming from the radiator. Only way to know is to pull the splash shield and have a look.

i did and all i can really see is coolant on the lines next to the abs module

006.jpg007.jpg
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...