Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

Since winter is over I have replaced the special winter wheels I have used, and those dont have TPMS sensors fitted. So I where so lucky to get rid of the errormessage confirmation ... but that where not the case.

First both rear wheel where missing, then after 20miles RR gave readout. I tried to reprogram the sensors by the instruction in the manual, but never got any confirmation by a chirp from the LR that still where missing before the procedure.

Now a few days later I'm missing three out of four sensors.

I tried to read online, and there are both types powered with battery that should last for 7-10years and other types that are selfpowering. My STS is a bit more than five years, so it sounds a bit early for replacement, but if they are battery powered it might be a good reason. Sensors are a bit costly (since I probably have to replace all four). Can battery be replaced separately?

Can it be something else?

Thanks in advance.

STS 2005 V8 (1SF)

Sedan DeVille 1995 4.9L

Link to comment
Share on other sites


....I tried to reprogram the sensors by the instruction in the manual, but never got any confirmation by a chirp from the LR that still where missing before the procedure.

Is this the procedure you used?

Use a fairly strong magnet. If this procedure fails, use a larger magnet.

1) Ignition ON.

2) Press LOCK + UN-LOCK key fob buttons until the horn chirps.

3) Starting with LF tire, hold the magnet against the valve stem

until the horn chirps. Then RF, then RR, then LR. After LR, horn

will chirp twice to indicate programming is complete.

There is a timer running that allows 1 minute between wheels and

5 minutes total elapsed time.

....Can battery be replaced separately?

No.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Hi Jim,

I tried to use fill/de-fill air to do the same thing, and the two first wheels where ok. But I can make the procedure again with a magnet, perhaps that is why I miss so many sensors now - my failing attempt. I have some small but very strong neodymium magnets, I try with them.

/Oscar

STS 2005 V8 (1SF)

Sedan DeVille 1995 4.9L

Link to comment
Share on other sites

Hi Jim,

I tried to use fill/de-fill air to do the same thing, and the two first wheels where ok. But I can make the procedure again with a magnet, perhaps that is why I miss so many sensors now - my failing attempt. I have some small but very strong neodymium magnets, I try with them.

/Oscar

Magnet experiment failed, and no reply on adjusting airpressure. I have ordered four new sensors, if something else shows to be the problem I have them for my winter tires.

/Oscar

STS 2005 V8 (1SF)

Sedan DeVille 1995 4.9L

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...