Jump to content
CaddyInfo Cadillac Forum

Valves ticking at start up


tommysls

Recommended Posts

Started the sls yesterday morning and heard what sounded like valves ticking - only lasted about a minute and noise disappeared. Also did same thing this morning. Oil level is fine and indicator states 75% oil life.

Otherwise she runs fine.

Suggestions appriciated.

Thanks

Link to comment
Share on other sites


Looks like you need a couple of WOTs to blow out carbon deposits resulting in cold piston slap. This is a known problem and easy to fix.

The saddest thing in life is wasted talent

Link to comment
Share on other sites

If a couple of WOT's don't help, I would advise adding 1 quart of Marvel Mystery Oil when you next need oil.

MMO is not a miracle cure and will not fix broken parts, but can work wonders unsticking lifters and rings.

-George

Drive'em like you own 'em. - ....................04 DTS............................

DTS_Signature.jpg

Link to comment
Share on other sites

Your lifters may be gummy and sticking, the MMO will endevour to clean them up for you, I have used it and have had good results with it quieting down lifters, you have nothing to lose.

Early on sailors navigated by the stars at night and the North star became the symbol for finding ones way home. Once you know where the Northstar is you can point your ship in the right direction to get home. So the star became a symbol for finding ones way home or more symbolically even finding ones path in life.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...