Recommended Posts

My '95 Seville has the Homelink with the red lamp. Nothing I could do would program my garage door opener, because of the "rolling code" garage door openers these days. After researching, I have found that GM vehicles '97 and under have the Homelink red lamp system which worked with the non rolling code garage openers.  Beginning in 1998 mode year,  Homelink then switched to the amber light system, which means they are equipped to program the rolling code garage door openers of today. Off to the junk yard I went today. Got really lucky, found a '99 Deville, and removed the Homelink transmitter, needing only a phillips screw drivers and wire snip pliers.  The harness is NOT interchangeable between the red and amber systems. You must take the harness plug with it (just snip the two wires a few inches away from the transmitter). I did a bench test first before I installed into the car to make sure it was going to work (just connected a 9v battery for the power), and it worked. It installs in the standard bracket with just a little patience, and cut the old harness plug off the harness, and crimped in the new one, cleared it, programmed it to the controller remote, and it now works !!!! Long story short: if you have a '97 or earlier car, and a newer garage door opener, throw away the red lamp Homelink and install the amber light unit.

Share this post


Link to post
Share on other sites

This has me thinking.

Both of my 97s will not program to my garage door opener.

I thought they were amber though. (I installed them)

I have never found one that had a different plug. I have a spare as well. Thank you for posting this. I wish you had a picture of the 2 plugs to see the difference.

If I ever get back to it I will post back here.

 


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites
5 hours ago, rockfangd said:

This has me thinking.

Both of my 97s will not program to my garage door opener.

I thought they were amber though. (I installed them)

I have never found one that had a different plug. I have a spare as well. Thank you for posting this. I wish you had a picture of the 2 plugs to see the difference.

If I ever get back to it I will post back here.

 

Play it safe. Go to a junkyard and take one out of '98 or later. If you already installed the amber units, but did not use their plug, then that could be the problem with them not programming. The amber light units have a three trace plug and circuit board connector, the red light unit have two trace; not interchangeble. I already installed the unit, so I may have a hard time taking a picture of the new plug, but I can take pic of the old plug. They are both two wire plugs. The red light uni ('97 and older) unit has an orange wire and black wire. The amber light unit has an orange wire and a blue /white wire.  Crimp the orange to orange, and the black to the blue/white. The picture shows the two and three trace units, that why you need the plug also when making this changeover to a '98 and later unit.

old and new units.jpg

Edited by CampoCougar
corrected lines

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.