Recommended Posts

Hello< We have an 1995 Deville - ac compressor won't engage, replaced low side cut out switch, Check all related fuses( that i can tell), Fans work, Ran diagnostic thru cars code system - nothing come back, swapped relays - seems like they are good, AC Control panels to function properly - all functions switching and working, just no compressor engaged,  refrigerant levels appear to be in range. Kinda Stumped - any advice or useful info would be appreciated. Thanks in Advance

Edited by AdvancedAuto

Share this post


Link to post
Share on other sites

Sudden no AC? Could be a bad compressor clutch coil. The pull in coil can sometimes fail and there will be no way to pull the clutch in. 

Or....sometimes the air gap wears into excessive gap....and the coil can't pull the clutch in....or it only happens when the engine parts are hot and expand. 

Both the AC coil and clutch plate can be swapped with the compressor in the car. No need to pull out the Freon. 

Most AC shops will simply recommend a complete new AC compressor assembly. They make more money that way. 

The actual style of the assemblies varies based on what brand of compressor etc you have....but the principal is the same. The brand can vary depending on year and engine etc. Some cars may have 2-3 different brands of compressors used on the same engine and year. 

I had one go out recently on a non-GM product...of course it happened on the hottest day....taking daughter to airport in rush hour....just as we were getting on highway.. 

Typically around $50 in parts. 

compressor-clutch.jpg

Share this post


Link to post
Share on other sites

I agree with above.

Unplug the compressor and see if it is powered when AC is on max cool (comp should be on)

If you have power at the plug then it is a compressor issue.

No power, something else.

As for the clutch replacement I wish it were that easy in NY. I have tried so many times but the rust factor just sucks trying to get them apart


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Ok. 

Recheck both pressure switches.

How do you know there is proper charge?

I am not sure if you have the Climate control Off and Warmer to get into diagnostic mode.

If you do then the codes will have to be run and cleared from the ACM


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

low a/c freon ao46 present? lCear the codes in the ac module through dash and try that.. Might need freon .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.