Recommended Posts

My 91 Eldo just had the dash go dark. No lights anywhere. No codes either. It runs and drives OK but the dash going dark is a problem. It did it while I was driving and came back by itself. It did it numerous times but never quit running. I have the battery on a charger to see if maybe it is the problem. Any suggestions?

Share this post


Link to post
Share on other sites

Try searching the archives.  If I recall there is a power supply.  My 91 never gave me trouble, but my 86 Corvette needed to be sent in to be repaired.  


Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

Drop the drives side hush panel and check the connection plugs along with all the fuses and relays

and have a look.

 


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Still working?

 


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.