Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

Hello. I have a 2007 Cadillac CTS 3.6 and I’m having an issue with the ac system. Ac blower blows great but the compressor is not coming on. On the ac control panel the “ac off” lift stays on constantly no matter what buttons I press also on the radio screen the message cones up “service ac system”. I made it as far as checking the fuse which is good and I swapped out the relay and it’s still the same. Just wondering if anyone can help point me in which direction to go from here. Any help is much appreciated 

Link to comment
Share on other sites


You prob. need a r-134 charge.  If the system is out of r-134 then the compressor wont engage.

You could buy one of those a/c recharge kits at your local parts store and DIY if your handy.

https://www.walmart.com/ip/Supertech-R-134a-Combo-Kit-18-Ounce/105656096

 

 

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...