Recommended Posts

Help just bought a 2005 sts. The first day no problems. The second and third day. I go to start it and it won’t start. But have power everywhere else. I had the battery, alternator and starter tested and their fine. If I jump it with cables and a car it will start and will start a couple times after that. Then the next morning dead again. Please please help me. I love my car but this is crazy. I’ve never had a problem like this. 

Thank you so much thank you for the help in advance

Share this post


Link to post
Share on other sites

Assuming the battery is not original, old, weak or worn out.....sounds like the car might have a parasitic drain....so a computer,  module or relay may be staying turned on and draining the battery.

Share this post


Link to post
Share on other sites

is the battery 'fine' but discharged or low on charge when it won't start?  Or are you saying that the battery is fully charged but the starter is not engaging?


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Hi I took the car this morning to a auto repair shop that doe starters, alternators & batteries. Told them my problems. I also told them I had gone to auto zone and they had said that my battery was fine. They immediately put it on their battery tester and the battery started out fine. But then dropped down. So I changed the battery and so far it’s working just fine. 

Thank you for taking the time to respond. 

Share this post


Link to post
Share on other sites

I've had batteries act as yours and sounds like it had a bad cell; at full charge it would seem to be okay, then quickly lose the cell and fail to start vehicle.  I think your start problem will be corrected (with the new battery).

p.s.  This can even occur with a fairly new battery.  I just had the same (or very similar) problem with a six month old motorcycle battery that just wouldn't hold charge in one of the cells.


Chuck

'17 XT5, '04 Bravada........but still lusting for that '69 Z-28

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.