Recommended Posts

93 Deville 90k one owner fla beauty.                                                                                                                                                                                                                                                                                                                                                        The climate control display died.  All functions still work.  All fuses and relays good.                                                                                                                                                                                                                                                       Any ideas to fix or just replace unit?     Pics to follow.


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

I would try to approach down a diagnostic flow like this:

Is the display getting power?  Oddly enough this can be rarely be solved by cleaning and reconnecting the battery cable stack -- there are multiple positive cables coming to the battery and one is not getting a good connection. 

If the control display is getting power then check to see if it is simply turned too dark

If it is getting power and it is not commanded off then it may be malfunctioning and needs replacement.


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Bruce ,  all unit functions work.  Just no led display on screen.                                                                                                                                                                                                                                                                        Just have to guess on settings.  Display did work when i got the car but display sorta fizzled out.'                                                                                                                                                                                                 Its 25 years old so its expected.   All other fuel/speedo displays work.  fuses and relays good and checked under dash and hidden also under hood.                                                                                           i figure the led display is shot.    Checked with Logan but he dont fix them.                                                                                                                                                                                                                                               Any more ideas before i pull it out and get a replacement?


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

I have seen this happen before on other vehicles, and sometimes a firm tap on the screen with your finger would get it working.

Usually, the problem WILL return.  If another tap/poke fixes it, I would go about disassembling the climate screen unit, and reflowing any solder points you see

 

It is fairly rare for the screen itself to actually fail, it is generally the connections that give up.  heating and cooling several hundred thousand times does a great job of weakening any and all solder connections.

Share this post


Link to post
Share on other sites

Gonna head to pic a part here in largo and get another one.   will replace it when i get home to NY.                                                                                                                                                                                               all the functions work just no led display.  So Im lucky on that.                                                                                                                                                                                                                                                                       Good  thing i have a heated garage and plenty o tools.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               I am just wondering how the face panel is held on.IT looks like its held on by clips.                                                                                                                                                                                                                               I think a gentle pry on the edge will release it.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              Anybody know for sure?


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

No luck at the Largo pic a part for a climate control unit.  The dash stuff was gone.                                                                                                                                                                                                                              One cad in the Orlando yard so gonna check it tomorrow.                                                                                                                                                                                                                                                                              If no good i will check Daytona and the LKQ yards off 95 on my way north.                                                                                                                                                                                                                                               There are a few on flea-bay for over $100.


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

No dice at the parts yards on the trip home.  Found one local in ny  for $40 bucks so gonna swap it out.

Gotta check the pass. side accuator/air mix door operation too as the heat output is weak.      Hope its not the heater core but from the posts I see the core is accessed from inside the car  so swapping it out will be easy. Flushing it is not a option because its winter here in NY and dont want a ice rink in the garage.

A A A A Anew core is only $30 bucks.  The only PIA is the heater hose connections in the engine bay.

Put 2000 miles on this Deville since I got it and drove it from Fla. to NY with no engine or tranny issues.   Much nicer than my old faithful winter rat Buick which is waiting for a new owner. Only 212,000 miles and runs like a watch and started every day buried in the snow.

 It served me well for 6 years!  Will miss the old girl!   Hope the Caddy serves me as well!

 

 

 

buick 1.jpg


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

gosh, I am not sure why your posts are displaying that way.  I fixed the last one by replacing spaces with paragraph returns.

Sorry the parts search was not successful.  Hate having the heater core out in winter!

 


Bruce

2016 Cadillac ATS-V gray/black; 2013 Cadillac ATS 2L Turbo Premium (Wife's)

Follow me on: Twitter Instagram Youtube

Share this post


Link to post
Share on other sites

Your probably going to need a bcm, located behind the glovebox on top of the heater core box

Share this post


Link to post
Share on other sites

Got a new climate control today at a local yard for $35 bucks.

Guy sez its tested so I will install it tomorrow.

BAR:  Hope its not a BCM I think its just the display as it fizzled out on the way home yet all the functions work.

Main worry is the weak heat output.  Since all 3 hoses are boiling hot at the 3 way "T" I figure the core is not plugged.

Gotta take out the glovebox and check the accuator operation and prob. pull the cover over the heater core to                                                                                                                                               to  see if its evenly hot across the face.  I see other posts of the heater core being plugged in these cars but                                                                                                                                                 the hot in and out heater hoses make me think its a bad accuator.

But Im lucky this core can be removed easily from behind the glove box !                                                                                                                                                                                                           My Buick core is the same way as I had to replace that one last year.

Cold weather like this makes me love my heated garage!

_cadillac_deville_climate_control.jpg


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Again I will ask how is the panel over the climate control is held in.                                                                                                                                                                                                                           I guess as it looks to be one full piece covering the climate control/PRNDL display/and fuel guage.                                                                                                                                                                 I dont see any screws and assume its held in place by clips like the radio surround as I swapped out the                                                                                                                                                        dead cassette/am/fm radio for a factory cd/am/fm unit I had on the shelf.


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Maybe this is a cell phone. 

I am not sure if that is possible or how that works but it is kind of confusing.

It could be formed like you are thinking. Just a pressed fit into the dash


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Rock:  Using a PC.

From pics I see elsewhere there are  screw holes on either side near the base of the bezel.

Dont wanna bust up that nice dash!

So gonna be some heavy disassembly in my future!

Anyhoo gonna do the easy glove box removal and check the accuator.

If its not operating correctly prob. just disconnect the power arm and peg open the door to HOT!

Till I get a new accuator.

Just wondering if the climate control being blank causing the temp problem.

But I can hear the duct doors operating when i switch from defrost to a/c dash etc.

Gotta have HEAT cuz Im freezin!

 

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

It will cause issues. Likely in limp mode at best.

Which unit is the one you want to remove from the dash? The display unit?


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Rock;  Yes i want to remove the climate control unit as it has no display yet all functions work.

The fuel center display and operation does work.

Prob. gonna do that today.

I did pull out the glovebox to check the accuator and temp door operation

The accuator works and moves both the temp door and switches to defrost mode so I know

that the operation is correct yet the air is only lukewarm while all 3 heater hoses at the "T" are hot.

So I figure the heater core is prob. plugged.  Since its winter and freezing out flushing the core

is gonna be near impossible with the weather its either live with it or swap the core out.

I DO have compressed air and wonder if i put air pressure to the core if that would blow out the crud and sediment?

Not too bad because access is inside the car and the only PIA is the hose connections.

Just gotta figure out how to bull the panel/bezel over the units.

caddy T.jpg

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Not my pic (my T and hoses still have the factory spring clamps).

My accuator /removed glove box and dash pics too large to post here.

 

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

I usually do not recommend forced air in the coolant hoses.

I would attempt to back flush from each side

So to be sure here. When coolant is hot.

What does each pipe from the heatercore feel like?

They should be equally hot.

Core is plugged if one side is very hot and other is luke warm.

To flush the core I would unhook both sides and flush from the luke warm side. That should back flush it. Once it flows you can flush it both ways. 

If the core is equally hot on both sides it would be a blend door problem. 


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Roc.......All 3 hoses I can reach near the T are equally hot.

The accuator and temp door movement brings them both to the stops and defrost when

max temp. selected or move to the other stops and flow out the dash

when a cooler temp is selected.

So Im sorta stumped on a clogged core or a 1/2 way clogged core from other posts I

see elsewhere.  I prob. will pull the cover off the core and actually feel it for equal temp

across the face then go from there.

 


93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

If both are equally hot then I doubt it is a flow issue.

If the actuator is working properly I would suggest checking the blend door itself. Maybe the door that the actuator controls is not moving.


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Blend door is operating freely from stop to stop.

Can see and feel the blend door arm movement with both the accuator

attached or it unhooked and manually moving it.

Gotta take off the cover to the heater core and feel the complete

face of it for constant temp top to bottom.

From the posts I see elsewhere its prob half plugged so the heat is weak.

Pics too big to post here.

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

core.jpg  

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Finally resized the pic of what Im posting about and  lookin at.

Took off metal rod for blend door and it moves freely and moves stop to stop.

Im thinkin plugged heater core.

 

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

Do you lose heat as the car is driving, idling? Do you have heat and then a cold air pocket?

Share this post


Link to post
Share on other sites

Just lukewarm heat all the time.

Burped the cooling system to make sure no air pockets too.

Gonna have to either flush the core or replace it.

 

Still gotta swap out the climate control unit.

Waitin for my FSM so I can figure out how to remove the face panel

aka bezel over the cruise control and fuel center.

 

Edited by sonjaab

93 DeVille-13 Chevy Impala

72 GTO - 77 Triumph Bonneville

84 Z-28

Syracuse NY

Share this post


Link to post
Share on other sites

I would not do anything until you get the display working.

I am pretty sure it defaults when there is a problem. And if it does I am not sure what the temp would be.

Have you tried manually holding the blend door one way or the other to see if it changes?

 


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.