Jump to content

Stiff Shifter 1997 Deville


rockfangd

Recommended Posts

Hi All. 

So unfortunately I have to drive my D'Elegance this winter. I found it has a few issues with the cold.

I replaced the battery today as it could not handle it.

The shifter is so hard to move I am afraid of breaking something. It is fine when it is warm out and when it warms up but not when cold.

My 1996 was the same way but not as bad as this one. I ordered a new cable from the dealer this morning. I am just hoping it is only the cable and not something in the column or transmission. Anyone have any issues with these?

On a side note the front end sounds like crap as well when cold. Rides nice but makes nasty clunking noises when hitting small bumps. There again when warm outside 60*+ no noise.  I have new front Arnott struts but cannot find the rest of the parts needed to assemble them. They have been sitting since last year because of this. If desperate the only thing I can think of is to buy a used set and disassemble them to get what I need.

Happy Holidays to all. 

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites


Hi Bruce. Both.

When I took it out of the garage a few weeks back it was stiff. When outside it is even worse

 

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

There is a ball in socket type joint on top of the column that dries out and needs lubricated. Drop the black hush panel, pull the second panel out that covers the topside underneath of the column and then the thin piece of metal held in by 4 7mm bolts. Finally, the column drops down with removal of 4 13mm bolts. The ball and socket joint is on the top side.

  Your sway bar links up front might be the culprit for the noise over bumps.

Edited by barczy01
Link to comment
Share on other sites

Thanks Barczy. I will drop the column and try that.

Links were replaced a few years back with greasable ones.  I changed them due to the noise. MY next try is the swaybar bushings

Update. 

I dropped the column this morning and lubricated the pivots. I ran it up and down about 20 times. I left the hush, and lower dash panel out until I find out if it helps it. This way it will be easier to drop it again to do the cable.

I have already done the transmission side before when I first noticed the issue.

I will let you know what I find.

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

Well I dropped the column today and replaced the shift cable. Took me about an hour to complete. 

I felt I should post  picture of the pivot at the top of the column. I used a good quality white lithium grease and worked it really well.

Before it was tight to drop to first gear. Now it is smooth all the way.

I then hooked the cable up. Hopefully this problem will be a thing of the past.

Thanks all

column shift.jpg

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...