Jump to content

Battery voltage swings


Fsunut

Recommended Posts

My voltage rages 14.5 to 14.3 while driving, but it has dropped as far down as 9.8 which is when the battery saver mode kicks in.  This has happened twice now.  Advance auto has checked the battery and charging system and tells me they are functioning okay.  Does this point to the voltage regulator as being the culprit?

 Thank you!

Link to comment
Share on other sites


  • 2 weeks later...

I suspect you have either worn out brushes, or the common problem of sand and oil getting injested by your alrernator.  One thing you can try is to disconnect the battery, rwmove the plastic shield, and metal access port, then using a small finished nail, stick it in the hole on the back of the alternator closest to the center shaft.  Wiggle it a little to move the brushes, and free them if they are stuck in sand. Then spray some wd-40 into The hole to wash away some grease that could be holding the brushes back.  Then insert the nail Again, and wiggle it.  

If you are up to it, you can remove the alternator, disassemble it, and clean out all the sand and oil from the  inside.  Use the finished nail in the hole to hold the brushes back as its placed back on the shaft.  Be sure to mark the alternator prior to disassembly so you know how the two halves fit back in place.

i either case, do not spray too much wd-40 as if too much floods the bearings, it could thin out the grease i side it, and cause it to get washed out of the bearing housing leading to a shorter bearing life.

Link to comment
Share on other sites

On ‎10‎/‎1‎/‎2018 at 10:08 PM, Fsunut said:

My voltage rages 14.5 to 14.3 while driving, but it has dropped as far down as 9.8 which is when the battery saver mode kicks in.  This has happened twice now.  Advance auto has checked the battery and charging system and tells me they are functioning okay.  Does this point to the voltage regulator as being the culprit?

 Thank you!

The ranging from 14.5 to 14.3 while driving seems high, it should drop back down to about 13 or so.  How often does it drop to 9.8?

Do you have a digital volt meter, try putting a volt meter on the battery while its running and see what you find.  A ranging voltage is usually an alternator problem.

Have you checked for codes?   Look at my signature and click how to check for codes and post the P codes here

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

  • 4 weeks later...

I believe if it stays above 15v or below ~8.6v it sets the "SERVICE CHARGING SYSTEM" message.

my car rides at 13.0v and i would not be concerned if its at 14.5 or even 15 for a few moments, but if it stays high or low for more than a few minutes i'd be concerned.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...