Sign in to follow this  
Fsunut

Battery voltage swings

Recommended Posts

My voltage rages 14.5 to 14.3 while driving, but it has dropped as far down as 9.8 which is when the battery saver mode kicks in.  This has happened twice now.  Advance auto has checked the battery and charging system and tells me they are functioning okay.  Does this point to the voltage regulator as being the culprit?

 Thank you!

Share this post


Link to post
Share on other sites

Could be a loose battery terminal. 

 


GM FAN FOREVER

Nice, clean, luxury= fine automobile

Share this post


Link to post
Share on other sites

I suspect you have either worn out brushes, or the common problem of sand and oil getting injested by your alrernator.  One thing you can try is to disconnect the battery, rwmove the plastic shield, and metal access port, then using a small finished nail, stick it in the hole on the back of the alternator closest to the center shaft.  Wiggle it a little to move the brushes, and free them if they are stuck in sand. Then spray some wd-40 into The hole to wash away some grease that could be holding the brushes back.  Then insert the nail Again, and wiggle it.  

If you are up to it, you can remove the alternator, disassemble it, and clean out all the sand and oil from the  inside.  Use the finished nail in the hole to hold the brushes back as its placed back on the shaft.  Be sure to mark the alternator prior to disassembly so you know how the two halves fit back in place.

i either case, do not spray too much wd-40 as if too much floods the bearings, it could thin out the grease i side it, and cause it to get washed out of the bearing housing leading to a shorter bearing life.

Share this post


Link to post
Share on other sites
On ‎10‎/‎1‎/‎2018 at 10:08 PM, Fsunut said:

My voltage rages 14.5 to 14.3 while driving, but it has dropped as far down as 9.8 which is when the battery saver mode kicks in.  This has happened twice now.  Advance auto has checked the battery and charging system and tells me they are functioning okay.  Does this point to the voltage regulator as being the culprit?

 Thank you!

The ranging from 14.5 to 14.3 while driving seems high, it should drop back down to about 13 or so.  How often does it drop to 9.8?

Do you have a digital volt meter, try putting a volt meter on the battery while its running and see what you find.  A ranging voltage is usually an alternator problem.

Have you checked for codes?   Look at my signature and click how to check for codes and post the P codes here


Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

I believe if it stays above 15v or below ~8.6v it sets the "SERVICE CHARGING SYSTEM" message.

my car rides at 13.0v and i would not be concerned if its at 14.5 or even 15 for a few moments, but if it stays high or low for more than a few minutes i'd be concerned.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.