Jump to content

Recommended Posts

  • 1 month later...

First off welcome to Caddyinfo

I am thinking there is a pressure problem.

When you first start the vehicle and turn on the AC does the compressor ever engage?

I assume the compressor is what failed leading to the service of the system.

If it failed how did it?

Was the orifice tube replaced, was the right amoung of pag oil put into each component?

Did you take it back to whomever serviced the system?

I would have the codes pulled and see what is current when the problem is occurring. 

A scantool will be needed to do this. not just a code reader as the system has to be accessed

 

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to post
Share on other sites

I think the key here is the restart, or probably more precisely the ignition recycle.

When it restarts is the A/C cool or does it blow "cold" air?

I agree with @rockfangd you should take it back to the people who replaced the compressor.

THERE IS ALWAYS ENOUGH TIME TO DO THE JOB RIGHT - THERE IS NEVER ENOUGH TIME TO DO THE JOB AGAIN !!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...