Jump to content
CaddyInfo Cadillac Forum

2000 DeVille, Check Engine Light Soon


Recommended Posts

It sounds like it is pure speculation that #4 is the problem.

What you really need is a scan tool that will display which cylinder is...in fact...missing. Anything else you are just guessing.

As for the posted video....wrong year Northstar engine. The 2000 uses coil banks....the 2006 uses individual coils.

Attached pic of a GM Tech 2 displaying the mis-fire graph.

2nd picture shows the coil banks used on 2000-2003 Northstars. Front is silver, rear is black. Except for color...they are identical and can be swapped between banks to see if the misfire moves with the coil.

post-2-0-33751300-1401292796_thumb.jpg

post-2-0-50956300-1401294851_thumb.jpg

Link to comment
Share on other sites


  • Replies 62
  • Created
  • Last Reply

Top Posters In This Topic

Goran,

I've got the cover on the right. Regardless, I see no spark plugs, just the round black washer looking thing. do i need a special tool, or does the rubber washer just pull out?

Link to comment
Share on other sites

Logan,

Thanks so much for hanging in there with me. I "thought" that black washer looking thing (boot) may just lift out, but I wasn't sure and didn't want to break anything. Your pic has cleared that up for me. The boot is in there tight so I guess I can just use a pair of needle nose to pull it out?

Bought a new plug to replace the one in cylinder #4 which I'll install today once I get the boot out. I'll then manually clear the codes. Mechanic used a code reader and that's why he suspected plug #4 was misfiring.

I'll inspect the coil again closely before I close things back up. My experience with coils was on the "old" black cylinder- type, that looked like a small beer can.

I guess that kinda dates me, huh!

If the Code appears again, I think I best spend the bucks, return the car to the mechanic and leave the diagnostic and repair to him.

Thanks again for all your help.

Steve M.

Maryland

Link to comment
Share on other sites

Hey Logan,

Replaced plug for cylinder #4 yesterday, ran the car and Ck Eng Soon message appeared again. Took the car to my mechanic and he checked the Codes and misfires were many. He cleared the codes and they did not show up again on the 10 mile drive home.

The mechanic suggess: 1. Rubber boot could be bad. 2. Coil could be bad.

He suggested I swap the boot with another cylinder and see if the Code follows to that cylinder. I purchased a new boot to have on hand if the boot proves bad and I'll do the swap tomorrow.

After-market coil is $200.00 at Auto Zone; $300.00 for OEM so I'm "hoping" I don't have to go that route.

Wish me luck!

Steve M

Link to comment
Share on other sites

mine was coil module. it had cracks all over it and was missing on one cylinder. I was surprised that a 4 coil pack would only misfire on one cylinder

GM FAN FOREVER

Nice, clean, luxury= fine automobile

Link to comment
Share on other sites

You can lose one coil...and the coil pack will look perfectly fine.

How the coil looks is not a good measure of the condition of the coil pack...of course obvious cracks and burns etc aside...

I used to carry a tested spare one in the trunk.

The coil pack is really just 4 individual coils molded in to one unit. So any one of the 4 can go bad...and look normal.

post-2-0-39561900-1401624118_thumb.jpg

Link to comment
Share on other sites

The front coil is gray or silver to match the engine cover and is about $2.50 more. The come with or without a small push-in module. The only two offerings on Rock Auto without the module are about $50 higher - go figure. If you get or carry a spare, a recycling yard front coil, tested on your car, is probably best because it seems to me that a set of good epoxy-embedded coils is as good as any. New ones are about $165 at Rock Auto.

While you are looking at the module, you can check G103, the ground for both ignition modules, which is on the front of the engine, low, near the transmission. It is on the same bolt as G104.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

  • 4 weeks later...

Hey Listers,

Thanks so much to all who responded, kindly and patiently, with excellent advice.

Recap: Initially started with Crank Case Position Sensor Code. Mechanic cleaned and checked connections and both were OK. Next, got a Mis-fire Code, Cyl. #4. Changed plug ($5.00) and that did not correct the problem. Replaced Spark Plug Boot ($7.00) on Cyl. #4 and that, so far, has resolved the problem. Next step would have been to replace the entire Coil, ($200.00); a much more expensive fix.

Thanks again to all those that hung in there with me over the long haul during this problem. This Forum is a Great Site and has helped me many times over the years.

POST CLOSED!

Steve M.

Maryland.

1986, 560SL, 99K

2000 DeVille

2007 DTS

Link to comment
Share on other sites

You can diagnose the coil by switching the front and rear coils, which are identical except for color. If the miss goes to the rear, it's the coil.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

  • 3 months later...

Hey Cadillac Jim

Steve M back with the same crank case position sensor (ccps) code. After replacing both sensors twice, installing new plug and then installing new plug boot on suspect cylinder, problem went away for about four months. Problem has now returned and local mechanic suspects it might be in the computer or the wiring? I think I should have replace all plugs and boots at that time that I could reach on the front of the engine; I can't reach the plugs next to the firewall. Your thoughts on this recurring problem will be appreciated.

Email response would be quicker!

Thanks much,

SMihaly137@aol.com

Steve in MD

Link to comment
Share on other sites

The computer is rarely the cause of any kind of issue - it is a very durable unit. It is likely that you will pay the mechanic to throw expensive parts at the problem. The service manual has a detailed troubleshooting chart for the codes in question.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

I've gone back through the thread and there was no crankshaft position sensor code ever posted. Nor was there a lean mixture code, which you said your mechanic once mentioned.

Please run the OBD codes yourself again and post them here and let's see what's up.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

  • 3 weeks later...

Hey Cadillac Jim,

Guy at Auto zone reading the Code P 0 3 0 4 this time said this indicates coil is bad, Cyl. #4 misfiring. No mention made of a bad

Crank Case Position Sensor! That's the same cyl. I replaced the boot and plug on a few months ago and the problem went away for a while.

Steve M

Link to comment
Share on other sites

P0304 is just a miss code. It's not a crankcase sensor code.

The miss code tells you which cylinder is missing but it doesn't tell you why it is missing.

The boot and/or plug could still be the problem, or it could be the coil. Other things that can cause a P0304 include a sticking valve, carbon between a valve and valve seat, a clogged fuel injector, a loose or bad connection on a fuel injector, etc.

But I would check out the coil. But before you do much, I would pull the plug and boot and make sure that the boot is clean, dry and tight, and that it was inserted onto the plug properly. Also, take the time to see if the plug was properly tightened, and that there is no dirt under the sealing surface.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

Hey Cadillac Jim & Bruce,

I'm starting to wonder if I should just bite the bullet and replace the coil at the front of the engine? One time (hopefully),

30 minutes labor and approx. $130.00. Previous Codes always identified Crank Case Position Sensor (CCPS) as culprit. Now, after replacing the CCPS's three times, a new Code indicates the problem is again a misfire with cyl. #4, that boot or that plug. And, that the culprit is the coil itself!

Repeatedly pulling the coil requires dragging my son out to the home each time; I'm sure that's getting old for him after working all day but he doesn't complain at all. If I want to swap #4 with #6 as suggested, I'd still have to wait an indefinite period of time to see if that resolved the problem. Then, start all over if the code did reappear. But, maybe that's the way to go. Decisions, decisions.

I thought when I retired I wouldn't have to make them anymore! Thanks guys, for hanging with me.

Steve in MD

Link to comment
Share on other sites

Steve,

I would swap the boots like barczy suggested. If the misfire does not move with the boot, then swap the coil packs to see if the misfire moves to #7. If it does, then you know it is the coil pack. Shotgunning a $130 part is an expensive proposition if it doesn't solve the problem.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

barczy01 has a good idea, though. Then, you switch the front and rear coils and see if it follows the coil.

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

swap the boot and plug from one cylinder to the other and see if it moves. You can swap the coil cassette from front to rear they are the same just a different color.

Link to comment
Share on other sites

Is there an echo in here? Here? Here? ...

CTS-V_LateralGs_6-2018_tiny.jpg
-- Click Here for CaddyInfo page on "How To" Read Your OBD Codes
-- Click Here for my personal page to download my OBD code list as an Excel file, plus other Cadillac data
-- See my CaddyInfo car blogs: 2011 CTS-V, 1997 ETC
Yes, I was Jims_97_ETC before I changed cars.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.



×
×
  • Create New...