Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

1999 DeVille with 120k miles makes yum, yum, yum ( not sweet sounding) noise between 16 mph and 22 mph. makes it in 1st gear. has new front tires and new front hub assemblies; just put on yesterday. sounds very similar to a wheel bearing on a car from the 70's era. makes noise accelerating, braking, turning or straight.

make the noise in neutral

feel just a slight amount of tickle at the foot throttle while making the noise.

just had SB 513121 hub assemblies installed on both sides yesterday, NOV/25/2013.

any chance that the rotors, just installed on JUN/14/2013, have warped again and are rubbing the brake pads?

the ELC has fallen and can't get up, so is there any way this is rear tires or rear suspension related?

any and all suggestions are welcome--I'm out of ideas.

Good Thanksgiving wishes for all.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...