Jump to content
CaddyInfo Cadillac Forum

Recommended Posts


I have to reach down and release it manually. I believe it must be a vacuum or an electrical problem. Can anyone suggest a fix? thanks, Joe

For sure it's not a vacuum problem. You have a solenoid that releases the park brake.

Under the rear seat bottom cushion there is fuse/relay box. I suggest you remove and install each and every fuse and relay ONE AT A TIME. Removing and installing those components will scrub any oxidation/corrosion from the electrical contacts.

Time required is less than 30 minutes.

OR, you could stop using the park brake.

Someone please move this thread to the Seville forum.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

I have to reach down and release it manually. I believe it must be a vacuum or an electrical problem. Can anyone suggest a fix? thanks, Joe

For sure it's not a vacuum problem. You have a solenoid that releases the park brake.

Under the rear seat bottom cushion there is fuse/relay box. I suggest you remove and install each and every fuse and relay ONE AT A TIME. Removing and installing those components will scrub any oxidation/corrosion from the electrical contacts.

Time required is less than 30 minutes.

OR, you could stop using the park brake.

Someone please move this thread to the Seville forum.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...