Jump to content
CaddyInfo Cadillac Forum

THermo?


95SLS

Recommended Posts

1996 Eldo. Just changed the oil, got her up to 65 2 days later and it says PC1258 (Overheat into protection mode) And Change engine oil now. 0% left. Changed coolant and put in pellets 2 weeks ago. Think it is the thermostat?

Mike

Link to comment
Share on other sites


I re set it myself before the oil change just to keep from looking at the message, Then changed the oil that day. He also says that the car shows only 8 volts and only clicks at crank plus the radiator is leaking. So I am thinking the Rad might have leaked into the alt and froze that up and the whole ball of wax went. Calling a tow truck now.

So much for taht able to run 200 miles after an overheat. It never showed low water light, went directly to Overheated and protection mode and No Oil life left. He shut it off then and said he listened to the stereo for 15 min while it colled down. So Who knows. Have to teach him how to break down.

ICE COLD in OHIO

Link to comment
Share on other sites

So Far, All we found is a loose hose bottom radiator. Must have went all at once and crapped all the coolant real quick. It kicked of like 15 codes that all went history when we put fluid in and started it. (Had to charge that battery)

I felt the oil and it still feels new, I wonder if it is really 0 life or if that just got triggered when the coolant left out.

In warm Garage in Ohio

Link to comment
Share on other sites

If you lost all the coolant and the engine got hot enough to enter limp-home mode, you definately want to change the oil. Right now!!!!

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Yea, it's cheap compared to the engine eh?

Took he fer a test drive and everything is ok.

It was all because of the loose hose clamp.

THe trouble is, that people who do these things don't always tell you what actually happened. Like, he says it lost coolant and went right into limp. It sounds more to me like he might have drove a while like that trying to make the exit. Killer is though, that I always hear that it will limp 200 miles without water, truth is, soon as the oil gets hot it shuts off totally. ( A good thing ) But I always dreamed of a great gettaway car having visions of the radiator being shot out and me going on 100 miles or so. So I'll have to scratch this one off my robbers list of get away vehicles.

Mike

Link to comment
Share on other sites

yeah if the engine oil got to hot it may have messed with the conditioners and lubrication properties of the motor. do you know where the coolant is leaking from? did you recently change the thermostat and not use a new gasget maybe? report back. do hoses look ok?

Link to comment
Share on other sites

Killer Boyb, the same thing happened to my wife on Sat with the 95. Now I was not driving either car when it happened but they both felt a gigantic loss of power and sht the car off ASAP. (as soon as shutting off AC comp showed up.) So I am not so sure it will limp home. Both said it acted like it ran out of gas, no fuel available. Plus, one has like 125K and the other 150K I'd be scared of cracking a head limping. I'd only do that in Detroit like around Dragoon st or an area like that. LOL

Mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...