Jump to content

94 sts


LAdams

Recommended Posts

Hi, I have 94 sts with a 4.6 engine. I am having what I think is an overheating problem. I have put the obd in the "coolant temp mode". My radiator cooling fans do not come until the temp is showing 227 degs.and the fans turn off at 214 degs. Anybody have any info on what the temp sensor swicth is supposed to come on and off at ?

Thanks for any info!

Link to comment
Share on other sites


Hi, I have 94 sts with a 4.6 engine. I am having what I think is an overheating problem. I have put the obd in the "coolant temp mode". My radiator cooling fans do not come until the temp is showing 227 degs.and the fans turn off at 214 degs. Anybody have any info on what the temp sensor swicth is supposed to come on and off at ?

Thanks for any info!

Sounds "normal" to me.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...