Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

My Cadillac has a new starter,after market, new battery 800 cca new cable from starter to battery,new negative cable all done because of corrosion found under the plastic original leads.with all that said why will my car start like a champ every morning but not after a couple stops at different locations?I also heard that maybe it could be the relay solenoid but I don't know where that is located is it in the drivers side door under the panels?

Link to comment
Share on other sites


I assume it cranks? If so, when the car is running in the morning, pull the vacuum hose off of the FPR (fuel pressure regulator) on the fuel rail. If there is any fuel present or leaking from the nipple, replace the FPR.

Link to comment
Share on other sites

I assume it cranks? If so, when the car is running in the morning, pull the vacuum hose off of the FPR (fuel pressure regulator) on the fuel rail. If there is any fuel present or leaking from the nipple, replace the FPR.

well when you say crank do you mean a click? because thats all i get is one click then nothing,I have power just no turn over and thats only after i drive it around then sometimes it starts and other times it doesnt.but every morning it starts like a champ.so this only happens after being driven to the store then to the bank then it wont start just a click.then i have to wait 30 minutes or more before it starts again.

Link to comment
Share on other sites

Crank or "turn over" are the same thing. If all you get is a click, then it is probably a voltage problem. Have the battery tested and check the cables for cleanliness and tightness.

Link to comment
Share on other sites

I have seen cars that would start like that and then when warmed up not want to start, from a bad ground. I would double check ALL ground cables as Ranger says.

Link to comment
Share on other sites

Depending on where the aftermarket starter came from it could be suspect. Sometimes cheap ain't cheap and you do actually get what you pay for. If it's an Autozone DuraLast (Don't Last) starter, I'd take the chance and replace it. You'll probably have to do it sooner or later anyway.

Link to comment
Share on other sites

If it just clicks, you may have an issue with a connection that is not tight at the starter or the starter solenoid is bad.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

  • 6 months later...

I had the same problem with my 95 , after replacing the Strarter, checking all the Connections several times I decided to Try a new battery even though the one that was in there was only one year old, THis was the first time in my 60 years of driving that I was able to return a Battery for Warente replacement and even then had problems getting them to agree till they put a 20 second load test on the darn thing, it droped to 8 Volts and stayed ther for over 30 seconds before gradualy returning to 12.2 .a second load test failed in 10 seconds, and the 3rd in 5 seconds.

Link to comment
Share on other sites

Try starting it in neutral and/ or move the shifter in and out of park and see if you can get it started.

I have the exact same problem on my 95 sls and suspect it may be the neutral safety switch

Don't let your first ride be your last ride in a Cadillac!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...