Jump to content
CaddyInfo Cadillac Forum

03 DHS Airbag Light On, SDM B0041


Recommended Posts

Hello all,

I have annoying problem with my 03 Deville DHS @ 95K miles.

When the car hits a pothole or hard bump the airbag light comes on. The code read is SDM B0041 which I researched is Side Deployment Module circuit open loop. Clearing the codes doesn't turn off the Airbag Light. After a few trips the airbag light goes off so by itself. BTW, The car has never been in a accident.

I would guess either there is connector problem or a sensor is going bad. Anyone else experience this or have a solution? Any wiring diagrams would be appreciated before I start tearing apart the car looking for things.

Thanks again.

Link to comment
Share on other sites


I have annoying problem with my 03 Deville DHS @ 95K miles.

When the car hits a pothole or hard bump the airbag light comes on. The code read is SDM B0041 which I researched is Side Deployment Module circuit open loop.

I recently had a similar code on my '98.

Found an ever so slightly corroded connecter under the passenger seat (near the rear left corner). Pulling back the lock tab, then yanking it on/off about a dozen times scrubbed it clean - no issues since.

Plugs near the floor level area are usually good suspects to start with, since they're subject to moisture, etc.

Link to comment
Share on other sites

I have annoying problem with my 03 Deville DHS @ 95K miles.

When the car hits a pothole or hard bump the airbag light comes on. The code read is SDM B0041 which I researched is Side Deployment Module circuit open loop.

I recently had a similar code on my '98.

Found an ever so slightly corroded connecter under the passenger seat (near the rear left corner). Pulling back the lock tab, then yanking it on/off about a dozen times scrubbed it clean - no issues since.

Plugs near the floor level area are usually good suspects to start with, since they're subject to moisture, etc.

Thanks for the quick advice.

I found connectors underneath the Driver's seat which I cycled on and off, made sure the connectors were on securely.

The airbag light is currently off, so time and mileage will tell if that was the problem.

Best Regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...