coleman33

1998 Cadillac STS: "Service Suspension System" and "Service Stability System warning:ABS/Traction Control

Recommended Posts

Cleared codes from(DIC). Then went for a drive. When I began to brake, "Service Suspension System" and "Service Stability System" warning appeared. The ABS/Traction control lights came on as well. When I pressed on the brakes, it felt like the traction was trying to engage? I continued to drive warning lights remained on however when I began to brake I did not feel the feel of traction engaging. Any ideas?

Share this post


Link to post
Share on other sites

I've been told the hub assembly on either or both wheels is going bad when those codes come on, or it could also be the sensors that connect to the hub.

Share this post


Link to post
Share on other sites

Go to the bottom of this post, click the link to retrieving codes follow the directions for your year and model and get the DTC codes and post them here, it will help us diagnose the problem, could be ABS related, but its hard to know


Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.