Jump to content
CaddyInfo Cadillac Forum

98 sls service engine soon light on.


Recommended Posts

My service engine light is on and i pulled the codes. P0171 and 174. It say's fuel trim system lean on bank 1 and bank 2. How can i fix this problem. Please help. Thsnks. I had a new used motor put in, in the begining of this year and have had this problem ever since. It doesn't run bad, a little rough at times but not for long at all. I replaced 2 oxygen sensors and that didn't fix problem, is there a problem with the pellum.

Link to comment
Share on other sites


My service engine light is on and i pulled the codes. P0171 and 174....I had a new used motor put in, in the begining of this year and have had this problem ever since.....is there a problem with the pellum.

Your year of engine does not use what GM calls a plenum seal, but you do have a vacuum leak somewhere on the intake system. Triple check all the vacuum connections at the throttle body; you might be able to hear the vacuum leak by probing around using a piece of rubber hose as a stethoscope. Be sure to include the power brake booster in your testing.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...