Jump to content
CaddyInfo Cadillac Forum

Recommended Posts

Okay so I took my 94 Cadillac sts to my mechanic the other day and he said the car drove fine to him..but I know my car and I know my car drove way smoother when I bought it couple months ago...okay it doesn't have the vibration/shake when its under load..climbing a hill or leaving a red light and I can't feel the shake at all but when the load goes away and probably at 40mph I can feel a bad vibration/shake and even when I come off the gas I can still feel it..I doesn't seem to be a powertrain problem but then again I don't know..my mechanic said it could be a problem with the computer but then again he doesn't really know neither just making assumptions...can anybody give me some advice..these are the codes that I have if they may help..

P020 (E020) ................................................. Open Fuel Pump Circuit HISTORY

P030 (E030) ................................................... ISC RPM out of range HISTORY

S038 ................... Electronic Level Control Exhaust Valve Short to Ground/Open CURRENT

S043 ............................................................ Speed Signal Fault HISTORY

S061 ............................................. Right Front Position Sensor Fault HISTORY

Link to comment
Share on other sites


Check your engine and tranny mounts, if you have dogbones check them for looseness

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...