Jump to content
CaddyInfo Cadillac Forum

p0741 another one


Recommended Posts

I bought a 99 deville recently and have many issues I will have to fix(already fixed some stuff)including the p0741. I noticed that when I start the car right after the car starts it makes a screeching sound for about 2 seconds and I can feel like something is grinding and then it goes away. so my question is if anyone with the p0741 issue had a similar experience with that sound oe is this totally a different issue not connected with the p0741 issue.

Note this only when i start the car.

Also should I change the coolant or do a complete flush?

Thanks

Al

Link to comment
Share on other sites


That code should have nothing to do with a screeching noise. Check your belt pulleys.

All you should need is to drain and refill, 50/50 Dex and distilled water.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...