Jump to content
CaddyInfo Cadillac Forum

ABS & Tractions fel ibland.


Jonny Wallin

Recommended Posts

Hej!

Jag efterlyser någon som är duktig och logiskt tänkande beträffande felkoder och mina problem.

Har haft en STS -99 sen februari som har haft samma fel hela tiden. Ibland så tänds ABS och traction kontrollampan. När dessa är tända så är:

Styrningen trög

Automatiska avaktiveringen av handbrom ur funktion

Värmesitsar ur funktion

Klimatanläggningen fungerar inte

och såklart inte ABS & Traction funktionen.

m.m.

Har nu lärt mig att detta är normalt så länge kontrollamporna lyser.

När dessa släcks efter ett tag (10-20 minuter) så fungerar hela bilen normalt igen.

Bilen har varit till Klintberg & Way (Svenska Bil) 5-6 gånger men dom klarar inte ut felet.

Det som har gjorts är utbyte av komplett ABS enhet komplett med ny styrdel.

Man har bytt ut data boxen för fjädring.

Man har dragit tillfälliga nya kablar mellan datorerna för att utesluta kabelfel m.m.

Nytt batteri. Samtliga jordpunkter är rengjorda och fixade.

Nya frächa säkringar i båda centralerna.

Felet är kvar. Men bilen kan vara felfri 3-7 dagar utan felkoder.

Jag har givit upp Svenska Bil.

Har läst på det Amerikanska forumet att någon (eller flera) bytt tändningslåset (kontaktmodulen) och problemet har gått bort. Vad tror ni?

Mina felkoder är följande:

IPC 1040C

PCM P1602C

SDM U1040C

RSS 1780C inbillar mig att detta är följdfel av koder ovan.

RSS 1783C

RSS 1785C

IPC U1255 inbillar mig att detta är följdfel av koder ovan.

IPC C1780C

Ibland så kommer även:

1644

1225

1611

För mig är allt förvirrande med Koderna. Men jag att det finns ideér på forumet.

Får väl se det som en utmaning att fixa felet själv. Vill inte ge upp en så underbar bil att äga och åka i.

Hoppas på hjälp. (detta blev visst en uppsats, sorry)

Hälsningar Jonny Wallin Segeltorp

Link to comment
Share on other sites


Hej!

Hmmm, kanske går bilen in i något slags override-läge efter 10-20 min..? Fast jag är inte den med mest erfarenhet här, förhoppningsvis kan någon annan ge dig lite utförligare hjälp.

Jag svarade mest för att tipsa om ett bättre alternativ än Svenska Bil. Om du kan tänka dig att ta bilen till Uppsala finns det en mekaniker vid namn Andreas Adestål, http://www.adestal.com/. Han kanske kan hitta felet.

Annars kan jag tyvärr inte göra så mycket mer än önska lycka till.

Hälsningar

Jonas

Link to comment
Share on other sites

Hej!

Jag efterlyser någon som är duktig och logiskt tänkande beträffande felkoder och mina problem.

Har haft en STS -99 sen februari som har haft samma fel hela tiden. Ibland så tänds ABS och traction kontrollampan. När dessa är tända så är:

Styrningen trög

Automatiska avaktiveringen av handbrom ur funktion

Värmesitsar ur funktion

Klimatanläggningen fungerar inte

och såklart inte ABS & Traction funktionen.

m.m.

Har nu lärt mig att detta är normalt så länge kontrollamporna lyser.

När dessa släcks efter ett tag (10-20 minuter) så fungerar hela bilen normalt igen.

Bilen har varit till Klintberg & Way (Svenska Bil) 5-6 gånger men dom klarar inte ut felet.

Det som har gjorts är utbyte av komplett ABS enhet komplett med ny styrdel.

Man har bytt ut data boxen för fjädring.

Man har dragit tillfälliga nya kablar mellan datorerna för att utesluta kabelfel m.m.

Nytt batteri. Samtliga jordpunkter är rengjorda och fixade.

Nya frächa säkringar i båda centralerna.

Felet är kvar. Men bilen kan vara felfri 3-7 dagar utan felkoder.

Jag har givit upp Svenska Bil.

Har läst på det Amerikanska forumet att någon (eller flera) bytt tändningslåset (kontaktmodulen) och problemet har gått bort. Vad tror ni?

Mina felkoder är följande:

IPC 1040C

PCM P1602C

SDM U1040C

RSS 1780C inbillar mig att detta är följdfel av koder ovan.

RSS 1783C

RSS 1785C

IPC U1255 inbillar mig att detta är följdfel av koder ovan.

IPC C1780C

Ibland så kommer även:

1644

1225

1611

För mig är allt förvirrande med Koderna. Men jag att det finns ideér på forumet.

Får väl se det som en utmaning att fixa felet själv. Vill inte ge upp en så underbar bil att äga och åka i.

Hoppas på hjälp. (detta blev visst en uppsats, sorry)

Hälsningar Jonny Wallin Segeltorp

Vi kan enas om elfel iaf. Rengör kabelskorna vid batteriet. Kontrollera att det inte är oxiderade batterikablar. Kontrollera huvudjordanslutningar och spänningspunkterna (generator, startmotor bilfront)

Du har ett fel i kommunikationskretsen mellan dina datorer. Var god skriv ut t.ex. IPC U1255 så man ser vilken typ av kod det är...

Kontrollera att kontakterna till dina datorer är fria från oxider och sitter på. Kabelbrott klämd kabel?

Link to comment
Share on other sites

Förvånar mig inte att datorbyte inte hjälpte...

If the DTC U1000 or U1255 is set in history with other DTCs set current or history, diagnose the other DTCs first.

If the DTC U1000 or U1255 is set current, this usually indicates a module that is currently not communicating or a configuration issue. For example, if the control module is configured for an option (i.e., OnStar, keyless entry, memory mirrors, etc.) that the vehicle does not have, it may expect to receive a message regarding this missing feature. This would usually occur due to the control module being recently replaced and incorrectly set up.

When the DTC U1000 or U1255 is current, the module that is not communicating may not even be listed on the Tech 2 on the Diagnostic Circuit Check /Class 2 Message Monitor list.

If the DTC U1000 or U1255 has set in history without other DTCs, replacing the control module that set the DTC is most likely NOT the solution. The module that has set the code is looking for an input from another module that is not communicating. Because the module did not receive an input that it is expecting to see, it sets a U1000 or U1255 which indicates there was a loss of communications. Look at the customer's concern (i.e., intermittent, erratic tachometer operation). This will probably be a better indication of the control module that is the source of the concern.

Du har både IPC och SDM U1040 - Loss of Class 2 Communications with ABS alltså ett kommunikationsproblem mellan ABS och instrumenteringen.

P1602 - Knock Sensor (KS) Module Performance (antagligen en följd av övrigt)

C1780 - Loss of Steering Position Signal

C1783 - ICCS2 DL Left Output Short Circuit to GND

C1785 - ICCS2 DL Right Output Short Circuit to GND

U1255 - Class 2 Communication Malfunction (Serial Data Line Malfunction)

P1611 - Loss of CVRTD Serial Data

P1644 - Traction Control Delivered Torque Output Circuit

Om vi nu tittar på din U1255.

Link to comment
Share on other sites

Förvånar mig inte att datorbyte inte hjälpte...

If the DTC U1000 or U1255 is set in history with other DTCs set current or history, diagnose the other DTCs first.

If the DTC U1000 or U1255 is set current, this usually indicates a module that is currently not communicating or a configuration issue. For example, if the control module is configured for an option (i.e., OnStar, keyless entry, memory mirrors, etc.) that the vehicle does not have, it may expect to receive a message regarding this missing feature. This would usually occur due to the control module being recently replaced and incorrectly set up.

When the DTC U1000 or U1255 is current, the module that is not communicating may not even be listed on the Tech 2 on the Diagnostic Circuit Check /Class 2 Message Monitor list.

If the DTC U1000 or U1255 has set in history without other DTCs, replacing the control module that set the DTC is most likely NOT the solution. The module that has set the code is looking for an input from another module that is not communicating. Because the module did not receive an input that it is expecting to see, it sets a U1000 or U1255 which indicates there was a loss of communications. Look at the customer's concern (i.e., intermittent, erratic tachometer operation). This will probably be a better indication of the control module that is the source of the concern.

Du har både IPC och SDM U1040 - Loss of Class 2 Communications with ABS alltså ett kommunikationsproblem mellan ABS och instrumenteringen.

P1602 - Knock Sensor (KS) Module Performance (antagligen en följd av övrigt)

C1780 - Loss of Steering Position Signal

C1783 - ICCS2 DL Left Output Short Circuit to GND

C1785 - ICCS2 DL Right Output Short Circuit to GND

U1255 - Class 2 Communication Malfunction (Serial Data Line Malfunction)

P1611 - Loss of CVRTD Serial Data

P1644 - Traction Control Delivered Torque Output Circuit

Om vi nu tittar på din U1255.

Link to comment
Share on other sites

Forumet hängde sig lite grann...

U1255 är den enda som överhuvudtaget är intressant just nu. Den visar att det är kommunikationsfel och det måste åtgärdas först av allt och lär också vara det som påverkar allt det andra..eller iaf det mesta.

Jag kommer att ge dig diagnosträdet på mail.

Tittar man på mitt dokument 1 hänvisar det direkt till dokument 2. Där förutsätter jag att Scan-toolen inte kan ansluta till alla enheter dvs till blad 3 som hänvisar vidare till blad 4..

Tittar man nu på 4 så ser man att det blir intressant vid steg 13..där kan man gå vidare neråt till punkt 71.

Är ytterst tveksam till att man gjort den här testningen hos Klintberg...

I ditt fall verkar det onekligen som om en enhet lagt av för gott..frågan är vilken. Frågan är om du har tillgång till Tech 2:an?

Link to comment
Share on other sites

Hej!

Jag efterlyser någon som är duktig och logiskt tänkande beträffande felkoder och mina problem.

Har haft en STS -99 sen februari som har haft samma fel hela tiden. Ibland så tänds ABS och traction kontrollampan. När dessa är tända så är:

Styrningen trög

Automatiska avaktiveringen av handbrom ur funktion

Värmesitsar ur funktion

Klimatanläggningen fungerar inte

och såklart inte ABS & Traction funktionen.

m.m.

Har nu lärt mig att detta är normalt så länge kontrollamporna lyser.

När dessa släcks efter ett tag (10-20 minuter) så fungerar hela bilen normalt igen.

Bilen har varit till Klintberg & Way (Svenska Bil) 5-6 gånger men dom klarar inte ut felet.

Det som har gjorts är utbyte av komplett ABS enhet komplett med ny styrdel.

Man har bytt ut data boxen för fjädring.

Man har dragit tillfälliga nya kablar mellan datorerna för att utesluta kabelfel m.m.

Nytt batteri. Samtliga jordpunkter är rengjorda och fixade.

Nya frächa säkringar i båda centralerna.

Felet är kvar. Men bilen kan vara felfri 3-7 dagar utan felkoder.

Jag har givit upp Svenska Bil.

Har läst på det Amerikanska forumet att någon (eller flera) bytt tändningslåset (kontaktmodulen) och problemet har gått bort. Vad tror ni?

Mina felkoder är följande:

IPC 1040C

PCM P1602C

SDM U1040C

RSS 1780C inbillar mig att detta är följdfel av koder ovan.

RSS 1783C

RSS 1785C

IPC U1255 inbillar mig att detta är följdfel av koder ovan.

IPC C1780C

Ibland så kommer även:

1644

1225

1611

För mig är allt förvirrande med Koderna. Men jag att det finns ideér på forumet.

Får väl se det som en utmaning att fixa felet själv. Vill inte ge upp en så underbar bil att äga och åka i.

Hoppas på hjälp. (detta blev visst en uppsats, sorry)

Hälsningar Jonny Wallin Segeltorp

Vi kan enas om elfel iaf. Rengör kabelskorna vid batteriet. Kontrollera att det inte är oxiderade batterikablar. Kontrollera huvudjordanslutningar och spänningspunkterna (generator, startmotor bilfront)

Du har ett fel i kommunikationskretsen mellan dina datorer. Var god skriv ut t.ex. IPC U1255 så man ser vilken typ av kod det är...

Kontrollera att kontakterna till dina datorer är fria från oxider och sitter på. Kabelbrott klämd kabel?

Hej Jonny

Ring Tobbe i Haninge 08-50027597 han kan allt om cadillacs

mvh

Stefan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...