Jump to content

01 Deville, Front brake rotor question


Scoutski

Recommended Posts

During routine maintenance I noticed that the right front CVjoint was slinging grease at the inner boot. I figured that this was also the cause of a wheel shake at speeds above 70 mph. While disassembling to R&R the CV (half shaft) I noticed that the bolt holes in the rotor were larger than the wheel studs. This allowed some rotational movement. The question is, Is this normal for the OEM rotors? There isn't any wear on the rotors or pads so, I am assuming that the OEM's have been replaced.

I used this forum to find out how to remove the axle shaft. Great site!

Scoutski

Link to comment
Share on other sites


....While disassembling to R&R the CV (half shaft) I noticed that the bolt holes in the rotor were larger than the wheel studs. This allowed some rotational movement. The question is, Is this normal for the OEM rotors?

Normal.

When the wheel lug nuts are properly torqued to 100 lb ft, I promise you there is no rotational movement.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

Thanks Jim, one less thing to worry about.

I am having a hard time getting the CV joint out of the transmission housing. A post on this site stated that there is a barrel type detent inside that holds this in place. I have tried prying this out but I am afrade to use excessive force for fear of breaking somthing internally. Will I have to use a BFH to get it out? Is there a special tool to remove it? I yanked on the shaft and pulled the boot loose, leaving the housing still in the tranny. Man what a PITA.

Scoutski

Link to comment
Share on other sites

Thanks Jim, one less thing to worry about.

I am having a hard time getting the CV joint out of the transmission housing. A post on this site stated that there is a barrel type detent inside that holds this in place. I have tried prying this out but I am afrade to use excessive force for fear of breaking somthing internally. Will I have to use a BFH to get it out? Is there a special tool to remove it? I yanked on the shaft and pulled the boot loose, leaving the housing still in the tranny. Man what a PITA.

Scoutski

Us a prybar between the tranny and the joint it will snap right out.

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

I used two pairs of vise grips to get mine out. I clamped the first one to the housing and then clamped the second one to the first one at a 90 degree angle. I then tapped on the second one and the housing popped right out!

Link to comment
Share on other sites

Thanks Guys, I finally got up the nerve and used a big punch and brass hammer. I was suprised when it popped out with just one tap. The retainer ring is on the end of the transmission output shaft, it is a wire spring like ring. The housing on the CV joint is tapered so that when installing, the ring is compressed into it's grove then it expands into the slot that is cut into the splines at the back.

Took it out for a test ride and still have a vibration that starts at 70 mph. Allready had the tires rebalanced, no help! Not shure what to do now.

Link to comment
Share on other sites

Yeah, they've GOT to be road force balanced....

I disagree.

The Michelins I have been happily cruising on for ~~66,000 miles have not seen a road force balance machine. A standard old spin balance at COSTCO is all that was required.

Not all 1998-2004 Seville (or 2000-2005 Deville) chassis cars exhibit the vibration/shake symptoms that some owners report as chronic. Tires would be the dominant variable; but there are other factors that cannot/should not be ignored. I'm not convinced there is a front-end/powertrain design problem based on my 170,000+ miles driving these cars.

Logan and others have been chasing this perceived "problem" for several years.

Jim

Drive your car.

Use your cell phone.

CHOOSE ONE !

Link to comment
Share on other sites

These cars are awfully sensitive to wheel/tire balance. Whether you call it a "problem" or not, I guess that depends on the individual.

But folks repeatedly report a normal spin balance doesn't work. It's clear that these vehicles are more sensitive than others. The 92-97 Seville, for example, doesn't have near the issues the 98-04 cars have. It's great that yours worked the first time without needing a road force balance, but I think the evidence indicates that your experience is an exception to the rule.

It didn't work with me either (just a spin balance). It took a visit to a shop with a Hunter machine to get it right. And it's still not TOTALLY right -- one of my tires has about 26 pounds of force. When on the front, it vibrates...but when on the rear, it's acceptable. On most cars, you can't even feel 26 pounds of force. But you can on the 98-04 chassis.

Jason(2001 STS, White Diamond)

"When you turn your car on...does it return the favor?"

Link to comment
Share on other sites

Jason, Thanks for the link to Hunter, I looked up the shops in my area that have the GSP9700. Lo and behold, the place that balanced my tires has one. I did not ask for or was optioned the road force balancing. I will go back today and have it done.

Scoutski

Link to comment
Share on other sites

It's typically more expensive, and sometimes they'll ask you why you think you need it. I paid $15 per wheel when I had mine done, which I didn't think was too bad. It took the guy at least an hour.

Jason(2001 STS, White Diamond)

"When you turn your car on...does it return the favor?"

Link to comment
Share on other sites

Called the tire shop to ask what kind of balancing they did. I found out that the GSP9700 was used but it had to be serviced by the rep since they did my tires. The boss agreed to redo all four at no cost. Can't get to till Monday so, we'll see.

Scoutski

Link to comment
Share on other sites

Called the tire shop to ask what kind of balancing they did. I found out that the GSP9700 was used but it had to be serviced by the rep since they did my tires. The boss agreed to redo all four at no cost. Can't get to till Monday so, we'll see.

Scoutski

That's good news, but I promise you the story won't end there. The first thing they're going to tell you is "if it's under 28# road force, you'll never feel it. That would be incorrect, you need to get them down to 10 or 12# for these cars, and beg and plead with them to exchange any tire that won't go that low. Try to ensure that the car doesn't sit in a parking lot overnight, since any flat spotting, though minimal, will give false readings.

You're on the right track here, and this is sound advice. Your more apt to get a good set of ROUND tires from Michelin than most other brands, at least that's been mine and other's experience on this board. JimD's statements prove it to me.

Never underestimate the amount of a persons greed.

Link to comment
Share on other sites

3 of my 4 Michelins are 11 pounds or less. One is at 4. That's as low as I've ever heard. The one is sitting right now at 26 pounds of force. He said they were able to correct it down from 38 or something. It's on the rear right now. I may have that one tire re-done at a different shop later on. I'm not sure if it's a bad tire, or a bad wheel, or if anything is even bad on it. No vibes right now -- but whenever I rotate this tire back to the front, I'm sure I'll begin to feel it again.

Like Johnny said, the guy told me that I don't feel anything under 28 pounds. He spewed some nonsense that it was BMW's spec and it's the most rigorous spec out there. Whatever. You can feel 28 pounds, especially on the front.

Jason(2001 STS, White Diamond)

"When you turn your car on...does it return the favor?"

Link to comment
Share on other sites

During routine maintenance I noticed that the right front CVjoint was slinging grease at the inner boot. I figured that this was also the cause of a wheel shake at speeds above 70 mph. While disassembling to R&R the CV (half shaft) I noticed that the bolt holes in the rotor were larger than the wheel studs. This allowed some rotational movement. The question is, Is this normal for the OEM rotors? There isn't any wear on the rotors or pads so, I am assuming that the OEM's have been replaced.

I used this forum to find out how to remove the axle shaft. Great site!

Scoutski

Scoutski,

Hey, if the tire balance doesn't work out... be sure to rule out that front motor mount...

I had a vibration at 72 mph with my '99 STS... bad front motor mount...

good luck

jim

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...