Jump to content

A Couple 95 sls 4.6 Questions and Issues


Recommended Posts

Well, I just fixed my ac compressor! did my belts, brrrrr its cold in there !!! woo hoo! :D .. sorry

anyways. I still have my main problems waiting for me.

If my car sits for a while (more than a couple hours) (or if i hadn't run it for long enough, it'd be right away) .. it takes a few sometimes several on off start on off start to get the *smurf* running. and it'll try the last couple but just sputter. then finally starts (quite embarrassing, but i don't care)

so, i did the tune up, fuel filter, plugs, wires... etc

i am gonna check my fuel pressure psi today.. but i also came up with an ecm error also a throttle control solenoid thing ( the pencil probe that pokes in the bottom of the block ... i replaced that .. didn't do shiz).

i'll let you know more after today, i really want to get this baby starting like a real caddy. any help is appreciated.

my next question is a body question...

i look all through google and caddy forums but never got what i needed..

I was trying to figure out if i could remove the clunky moldings on my sls doors, you know the chrome and plasticy thing there..? i was gonna take em off putty the holes and paint thedoors then the bumpers. make it a more clean look. however, i don't wanna go into it without knowing how to take em off properly..

Thanks.

Link to comment
Share on other sites


:welcomesmiley:

With the info given, I bet fuel pressure regulator for the slow start.

For the door trim, the 98 manual says (I am guessing 95 is similar):

Starting at the rear of the door, split the foam tape using a braided wire or a flat-bladed tool inserted between the molding and the sheet metal. If using a flat-bladed tool, protect the surrounding surfaces. Do not damage the paint.

Remove the door molding from the door.

Clean the old adhesive from the door and from any reusable molding with 3M General Purpose Adhesive Cleaner 08984 or equivalent.

Bruce

2016 Cadillac ATS-V gray/black

Follow me on: Twitter Instagram Youtube

Link to comment
Share on other sites

hm. when i went to go expunge the pressure from that valve, there was NONE. which leads me to believe this is the cause for the trouble starts. it seems as if each time I go to try and start again the poor thing has to rebuild the appropriate pressure in order to start. I've heard of an o-ring somewhere in the system that is prone to wear.. any hints or other possibilities?

Link to comment
Share on other sites

In that case it may be a leaky check valve at the pump. Try turning the key on, but don't crank. The pump will energize for about 2 seconds, then shut off because the engine was not cranked. Do this one or two more times to build fuel line pressure. On the last one, crank it like normal and see if that helps. You can check to see how bad it is by putting a fuel pressure gage on it and see what the pressure is when you turn the key on and how long it takes to bleed down.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...