Jump to content
CaddyInfo Cadillac Forum

my battery problem


Arash

Recommended Posts

Dear all members

A few days ago I complained about the battery problem on my 94STS with 90,000 miles. I cleaned both the battery's positive and negative terminals with boiling water and a worn out toothbrush in order to clean the oil out. I've never had any starting problem ever since and the battery is sufficiently charged and never empty. My DIC shows 13.5 volts.However, my battery eye is barely green and almost black when it should be a visible green. The battery is one year old. I also never got any warning in the DIC when my battery was dead every morning. Can anybody explain the reason for the battery eye and the lack of warning by DIC?

Thanks in advance

Arash

Link to comment
Share on other sites


I believe that the "eye" is only on one of the cells of the battery.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

I believe that the "eye" is only on one of the cells of the battery.

Typically second in on the positive side. That is the cell that ( in the old days at least) went dry first. A couple of years ago my Eldo showed a good eye. Battery was a goner. Try a load test. Unusual for a one year old battery to go bad but not unheard of. I once had two bad batteries right out of the box conseculatively. That was a fooler.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...