Jump to content
CaddyInfo Cadillac Forum

Emission results


Recommended Posts

'87 Coupe DeVille 93K miles. Last year my area began emission testing. My car passed with flying colors. Today it went this years test. Again it passed, but the results were much different. Is there a site I can use to diagnose what may have caused the levels to change? Emissions are a new ballgame for me. No codes in computer and I keep this vehicle well-maintained. Thanks....

GM Reman 4.1 engine Dec '08

Link to comment
Share on other sites


The condition of your ignition system will cause differences (plugs, wires, etc)

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

See my post in this thread for more information:

http://caddyinfo.ipbhost.com/index.php?showtopic=12860

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

See my post in this thread for more information:

http://caddyinfo.ipbhost.com/index.php?showtopic=12860

Thanks the link is a big help. Let me give some better info: 4.1L engine, 93K miles. Last fall I took a 4500 mile cruise. I had to use 2-3 tankfulls of 10% ethenol gas. Mileage dropped 3mpg. When I returned the OBD had a 'oxy sensor not ready' code(no other associated codes). I cleared that code and it has not showed up since. Although the code has been cleared, the computer still has that info stored in the history, so I'm wondering if I clear the computer RAM, and it runs on the default PROM program, might that help anything? I don't like clearing the RAM but....

The main troubling results were the CO(mostly) and the higher HC results.

Last year CO: standard=1.20% 2006 at High RPM=0.01/Low RPM=0.03

This year CO: standard=1.20% 2007 at High RPM=1.08/Low RPM=0.13

HC standard =220(PPM).......2006 at High RPM=45/Low RPM=47

2007 at High RPM=17/Low RPM=100

The other test results are very close to last year. I don't have enough knowledge about emissions. The car is very well maintained and used for long trips.

The Texas Clean Air website points to an Oxygen sensor problem and the OBD did have the 'not ready code' at one time. Do these results ring any bells with anyone? The car passed emissions but I'd like to nip any upcoming/current problem now. Thanks for any knowledgable advice.

GM Reman 4.1 engine Dec '08

Link to comment
Share on other sites

I intend to replace the sensor. Any tips to removing this? It's been in for over 2K hours, so it probably doesn't want come out. Normally I use a penetrating spray for some help, but I want to be sure using this stuff won't cause any problems for the new unit. I've found the part available from some online GM stores. Any recommendations as to a GM part vendor? Price range I'm finding is wide! $65 to $22....for the same genuine GM or AC Delco part! Thanks.......

GM Reman 4.1 engine Dec '08

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...