Jump to content
CaddyInfo Cadillac Forum

97 sable with 3.0 strange cooling trouble and no heat


billybob

Recommended Posts

hey guys. First thanks for all your help in the past and I know this is a caddy site. But if I could just get some help on my fathers 97 sable it would be a blessing. Seems it has a coolent problem the dam thing gives heat only when you pull the heater hose off let it run a little untill it starts flowing then stick it back on to get the coolent flowing then theres heat. The stat was changed and is 100 percent working we also flused out the whole system for like a hour so theres no blocks in the rad or lines. what gives think a bad water pump. The line we are pulling off is the heater hose line from the water pump to the heater core and it does take awhile to get a steady flow. Theres no leaks or noise comeing from the pump how would one tell. Car did have a overheating problem at one time also even without a stat in it. thanks bill

Link to comment
Share on other sites


You did not say if you flushed out the heater core, did you? Is the system full of coolant? What is the coolant concentration? Anything other than 50/50 mix will cause problems. Sounds like maybe the heater core is blocked or the waterpump is on the way out.

Link to comment
Share on other sites

May also be a "blend door" problem.

There were problems with the door in the heater system that allowed fresh air to blend with the heated air. It caused either cold all the time or heat all the time. Just a thought....

Link to comment
Share on other sites

thanks guys for your help i did flush the heater core and the whole system. I did check for air none. shouldnt once that heater hose is taken off the heater core wouldnt it shoot coolent out of the hose not just pump like its pissing. It is the line thats connected to the water pump itself. also coolent is the right mix its funny once you get it going it works for like 5 minutes and back to ice cold air again. Im thinking maybe a bad pump ???? like I said no noise or leaks?? from the pump could one go weak. thanks bill

Link to comment
Share on other sites

Sometimes people by-pass the heater core because it leaks and they can't eford to get it replaced. Or the heater by-pass valve is not opening maybe do to a vacuum leak or control panel problem. Or the heater duck door isn't opening, you can check this by removing the glove box or pull the corners in so that it falls open. Then with a flash light you'll see a white box with some wires going to it and a shaft go through it. As you move the cool to heat noble on the A/C control the shaft should rotate. And or the heater core is clogged, which is what wrong with my heater.

I got this information at the FORD FORUM under Taurus:

http://www.fordforum.com/

This thread should probably be moved to an appropriate location

Pre-1995 - DTC codes OBD1  >>

1996 and newer - DTC codes OBD2 >> https://www.obd-codes.com/trouble_codes/gm/obd_codes.htm

How to check for codes Caddyinfo How To Technical Archive >> http://www.caddyinfo.com/wordpress/cadillac-how-to-faq/

Cadillac History & Specifications Year by Year  http://www.motorera.com/cadillac/index.htm

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...