Jump to content
CaddyInfo Cadillac Forum

Missing O/D


Recommended Posts

I was driveing on the highway today on my way back from the beach with some freinds the car was working fine and i pulled in to get some gas, After leaving the car shifted fine through first second and third but when i hit over drive the car reved up and wouldnt move as if it was in neutural... So I pulled over and shut it off work again till i hit o/d, so I had to drive all the way home with the gear selector in 3rd i got home just not with very good gas miledge but i need to get the problem figured out does anyone no what it is it just kicks out and the service engine soon light comes on till i pull over and shut the car off.....

Any input would be great ill have to do it again and pull the coades off it while the ses light is still on.

user posted image

Defending Northstar perf a qtr mile at a time!!!!

Link to comment
Share on other sites


This was the symptom when my 96 transmission was ready for a $2500 rebuild.

Did you get any error codes? http://www.caddyinfo.com/readingcodes.html

You can try checking the fluid level, but loss of 4th in an otherwise shifting okay transmission is likely terminal.

Bruce

2016 Cadillac ATS-V gray/black

Follow me on: Twitter Instagram Youtube

Link to comment
Share on other sites

This was the symptom when my 96 transmission was ready for a $2500 rebuild.

Did you get any error codes? http://www.caddyinfo.com/readingcodes.html

You can try checking the fluid level, but loss of 4th in an otherwise shifting okay transmission is likely terminal.

This is what my seville did and it was the shift solenoids. It would slip as it shifted into 4th and eventually will only work in 2nd, changed the solenoids and all was fine.

Link to comment
Share on other sites

Pull the codes from the on-board diagnostics and post them - the codes will help narrow down the problem.

Kevin
'93 Fleetwood Brougham
'05 Deville
'04 Deville
2013 Silverado Z71

Link to comment
Share on other sites

I pulled the coades i got P094 meaning Transaxle Shift "A" Solenoid Problem (Vehicle Speed Sensor) if any one could explain what this means that would be great. :P

I also got S073 ................................................ Right Rear Accelerometer Fault

which also means??

Thanks for the help guys.

This is what my seville did and it was the shift solenoids. It would slip as it shifted into 4th and eventually will only work in 2nd, changed the solenoids and all was fine.

How much and how hard was this to do?

user posted image

Defending Northstar perf a qtr mile at a time!!!!

Link to comment
Share on other sites

There are two shift solenoids "A" & "B" that must be changed. It's all done from underneath. No need to pull the trans or rebuild. Kit is less than $100 and the pan & valve body need to be removed. A DIY job if you are mechaniaclly inclined.

Link to comment
Share on other sites

Where can I buy the kit? The dealership? is there anywheres cheaper than the other. Also was wondering if anyone has or nos where theres any diagrams of how to get at them.

user posted image

Defending Northstar perf a qtr mile at a time!!!!

Link to comment
Share on other sites

cadillac_caddy_sts,

When you get around to replacing the solenoids, can you take a series of pics and post them here for us?

That would be very interesting.

2003 Seville STS 43k miles with the Bose Sound, Navigation System, HID Headlamps, and MagneRide

1993 DeVille. Looks great inside and out! 298k miles!

IPB Image

Link to comment
Share on other sites

cadillac_caddy_sts,

When you get around to replacing the solenoids, can you take a series of pics and post them here for us?

That would be very interesting.

Yes if I deside to try doing it myself I will for sure.

user posted image

Defending Northstar perf a qtr mile at a time!!!!

Link to comment
Share on other sites

I just ordered the part in 111.47 plus tax... I was pretty happy with that because im thinking the 100 dollars you guys were talking about was in american? I am going to get a guy that my dad no's who specializes in transmissions to put it on this weekend at his shop.

Thanks for all the help and I just hope this definitly fixes the problem.

user posted image

Defending Northstar perf a qtr mile at a time!!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...