Jump to content
CaddyInfo Cadillac Forum

Search the Community

Showing results for tags 'front'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Cadillac Help and Discussion
    • General Cadillac Forums
    • Cadillac Grooming: Details on Detailing, Looking Good and Showing
    • Cadillac Builds and Project Cars
    • Cadillac Photography
    • Cadillac Master Craftsman Recognition Hall
  • Cadillac Clubs are Welcome on Caddyinfo.com
    • Cadillac Club Sweden
  • General Motors News
    • General Motors News
  • Cadillac Help and Discussion by Model
    • Cadillac CT5, CTS, STS 2005+, 04-09 SRX, CTS Sport Wagon (Sigma)
    • Cadillac V-Series Forum
    • Cadillac CT4, ATS
    • Cadillac XTS
    • Cadillac Deville, Eldorado, Seville, Fleetwood, Sixty Special
    • 2010+ Cadillac XT4, XT5, XT6, SRX
    • Cadillac Escalade, EXT, ESV Help and Discussion Forum
    • Cadillac Lyriq / Converj / Cadillac ELR
    • Cadillac XLR and XLR-V Help and Discussion Forum
    • Cadillac BLS Help and Discussion
    • Cadillac Companion Cars -- LaSalle, Buick, Chevrolet, GMC
    • CT6
  • Competitor Cars -- Cadillac Competitors
    • Competitors: BMW
    • Competitors: Porsche
    • Competitors: Mercedes
    • Competitors: Infiniti
    • Competitors: Others
  • Cadillac FAQ, How-To, Tips and Hints
    • Cadillac Owner Tips and Hints
    • Cadillac Links
    • Cadillac For Sale -- Private Parties or Supporting Vendors
    • CaddyInfo Forum Suggestions and Notes
    • CaddyInfo Polls
    • Green Technology, Future Power Sources, Fuels
  • Caddyinfo.com Supporting Vendors/Supporters/Subscribers Section
    • Crest Cadillac
    • Cardio-Doc on Wheels
    • Supporter's Cadillacs
    • CaddyInfo Supporter Section
    • B&B Automotive, LLC -- Northstar Repairs
  • New Members Section -- Introduce Yourself & Stay Awhile! Also, non-Cadillac related Topics
    • The 19th Hole Lounge & Member Introductions
  • CaddyInfo Lifetime Supporter's Topics

Product Groups

  • Forum Support Levels
  • CaddyInfo Forum Items

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Car Model and Year

Found 1 result

  1. Hi all. I have had a clunk in the right front of my Deville for as long as I can remember. I think it had it when I bought the car. Anyway I have given up a few times trying to figure out the cause, and I am starting to pull my hair out because it sounds louder now but I just cant detect the exact problem. Here is what it does. If you hit a bump on the right side only it clunks I cannot feel it in the steering wheel. Drives straight and wheel is straight If you hit a bump(speed bump for example) where both front tires contact, nothing happens It is specific to the corner only. I have replaced inner and outer tie rods. (inner had play when I bought the car) I removed and rebushed the lower control arm last year when I repaired the strut rod portion. I replaced the balljoint when I had the control arm out I replaced the hub assembly (noisy but no play) I replaced the sway bar links And lastly I replaced the whole strut with a donor unit (basically to see if anything would change). Nothing has solved the noise I have jacked it up by the body and checked for play, also inspected the subframe bushings which look surprisingly good for the year and miles I jacked it up by the control arm and checked for play. Nothing. I have tried bouncing the front end, grabbing the wheel and checking while on the ground. Nothing at all. I am down to thinking it can be sway bar bushings(I would think it would be noisy with both sides though) I inspected the swaybar and found no play or cracks Subframe bushings worn. I would not know how to find out if this is the problem. Replacement strut just as bad as old one. An expensive gamble for a new unit. I am baffled that as much noise that it makes that I cannot find the cause. I thought for sure that when I fixed the strut rod bushings last year that that would have cured it, but not with my luck. And another thing that has been driving me nuts. The clock is running faster than usual. It gained 9 minutes in a month. This is very common to these but I dont know why. Usually it will be 10 minutes fast after about 6 months but not lately. Maybe I will have to talk to the dealer on this one. Thanks all in advance for any insight
×
×
  • Create New...