Jump to content

Rusty

Registered
  • Posts

    39
  • Joined

  • Last visited

Everything posted by Rusty

  1. Trying to find the fuel tank level in the DIC. For example : how much fuel was used, how much remains. Anybody know how to do this ? Not finding the answer in the manual. Thanks.
  2. I have noticed that many of the newer CTS models that are not premium optioned do NOT have back-up sensors on the rear bumper or back-up cameras. I just purchased a 2012 performance CTS without this feature. It's a beautiful car, with low miles but I'm starting to have a bit of buyer's remorse. How many of you current owners find the lack of this feature an annoyance when backing to park ? My 15 year old STS , had this feature, along with tilt to curb mirror in reverse, also missing from the newer car(s) .
  3. My beautiful well maintained 2001 STS was totaled recently , and now the frustrating search begins for a worthy replacement. One of the reasons I kept it this long was the wealth of advice on this forum . I was considering a used AWD 3.6 L CTS , preferably with some decent options. Performance vs. Premium ? ( I still like wood trim ) Fog lamps aren't even a standard feature on cars today. Any advice from previous STS owners - who have transitioned to the more recent Caddies ?
  4. I thought P1633 was the only current code present when I cleared PCM codes previously - when the SES light went away . I just noticed P0125 code which was occasionally in history is now current.
  5. STS 116,000 miles . SES light comes on, with PCM P1633 code ' zero position ignition '. Light goes out when this code is cleared. Ignition switch was replaced 4 years ago . Battery is 7 years old , but output seems fine and car starts and runs O.K. Just curious - other than clearing the code every few days - anybody have any thoughts about how to approach this ?
  6. Thanks for the comments. Parts search results: Monroe P/N 40029/40030 were more $ than the OE AC/Delco so I've decided I'll probably use those. I'm not convinced there is "real" aftermarket replacement. AC /Delco 580-130, 580-131 for $985 del’d. from Auto Parts Tomorrow . Haven’t talked to them before but I will definitely call before I order. Amazon had the apparent low price of $350 ea. , but 3-5 week delivery. Wonder where they're coming from... I’m pretty well resigned to cough up the dough if I can be guaranteed the ride won’t be degraded while I still own it. A fellow Caddy owner remarked that if car maintenance costs $3,000 a year – 2 years in a row - time to get rid of the car. I will have easily passed the $3,000 outlay this year. Can only hope next year will be better.
  7. Decision time for sure. You will have to flip the coin for an eleven year old ride; there is no middle ground between "thrifty" and the "nice ride". BTW: the nice ride with CVRSS (F45 RPO) includes much more than automatic level control air bladders on the rear suspension. Monroe offers shocks (and struts) for your F45 suspension. Monroe shock part #s 40029 and 40030 available from Rockauto and others. Were it my car, salvage parts would not be an option. Not me. I would trade the car rather than install "passive" shocks/struts on a F45 suspension.
  8. 109,000 miles on the STS, runs great, except : ELC compressor is running a lot more lately ….. oil leaking around the right rear shock boot . Prices for OE shocks for the CVRSS suspension will concentrate the mind quickly. e.g. $ 469 ea. from GmPartsdirect. Other option might be salvage … What’s the consensus opinion about using other than OE parts ? I want to try to be thrifty but don’t lose the nice ride. : ) Has anyone had experience with passive shocks from Arnott Industries ?
  9. If you are creative...it can be repaired. All 4 of mine have been repaired at some point. I did get 1 new one from RockAuto. Turned out to be a China-made unit. I think all the eBay ones are 'repaired' units. The China unit I have (and using) is identical to the original. Right down to the plastic nugget. Since I noticed you mentioned plastic nugget - what's your favorite plastic nugget glue ?
  10. Thanks for your help guys. Guess there's no chance of repairing the part. Looks like a replacement / aftermarket regulator. I was told the cheaper ones on eBay are probably Chinese and might last 10 months(?) Or maybe I'll opt to buy the "better" higher priced ones from Mexico ...
  11. A sharp cracking sound occurred when the rear window was being raised. At first I thought something had hit the door, like a rock or bottle. Can hear the motor run- but not sure it will lower it - and now I'm reluctant to try for fear it might drop the glass inside the door. If it's the regulator is that going to be a PIA and big $ to fix ? I was planning on taking the door apart this weekend . Anyone encounter this situation ?
  12. I'll show this to the tranny shop mechanic. I talked to the local Caddy dealer service dept manager, and he seemed to be very familiar this bushing failure.
  13. Update: The transmission shop guy just said it's the "bushing" ( 3rd clutch housing bushing) - sorry not the bearing that needs to be replaced. I'm going to have to get to this problem after the first of the year.
  14. Thanks for the information - the drawings and photos are very helpful. But IF the needle bearing behind the seal is bad (evidenced by the movement) wouldn't you have to remove the tranny to get to this bearing ?
  15. 101,00 miles. I noticed a transmision fluid leak on the garage floor (on the drivers side) . According to a transmission shop the seal is leaking where the axle connects and there is ½” vertical play inside. I was told a new seal wouldn’t last because the bearing behind the seal is worn. So…. the transmission would have to come out to fix this. Estimated repair cost around $1,400 - $1500. Has anybody else seen this problem before ? Car still looks nice and runs fine, but can’t help wondering what problems I’ll be looking at next . I’m half considering moving on to a different car - economically that’s not going to make me feel any better - and I’m pretty sure it won’t be half as nice or as much fun to drive.
  16. The mechanic used a scan tool and stated that bank 1 sensor was suspect. I was told that the 2 front sensors were replaced- but that is not definite. He explained to me that all the sensors were functioning.
  17. 2001 STS , 95,000 miles. I replaced a destroyed catalytic converter ( Eastern Catalytic converter p/n 50410 ) and removed the resonator which was clogged with debris from the cat. After about 10 days PO420 code appears, scan tool indicated problem with left bank - and the front O2 sensor was replaced. Code set again, same O2 sensor replaced (?) at no charge. My mechanic says scan tool shows the sensor(s) working O.K. Code returns again - now what ? Any comments or help from the brain trust is appreciated.
  18. 2001 STS. No start / no crank pointed to starter replacement. After driving car home from dealer, severe loss of power occurred. The engine was laboring and felt like it was about to stall. Check engine light on. I noticed a burnt smell when I finally limped home and parked in garage. Brought back to dealer next day, coil wire (?) had supposedly came loose. The mechanic tightened it, and said that it didn't leave that way, and the clamp may have loosened. He explained that car was probably running on 4 cylinders. Next day the check engine light is still on and codes PCM PO420, PO410 were current. Cleared codes, but check engine light back on and PO141 is current. I noticed that on the bill for the starter replacement, there was no parts listing for an intake manifold gasket . Shouldn't a new gasket have been installed on a car with 84K miles ? Anyway, called the dealer and have appt. for next week. Since they were last to touch the car I feel they have an obligation to fix it - at their expense. Do you think there is any chance the cat converter or oxygen sensors were damaged ?
  19. The PRNDL switch checked out O.K. and power was available up to the starter. So, a decision was made by the tech to try replacing the starter. ( $268 parts + $ 255 labor) I haven't had a no start event since, and hope that finally corrected the problem. Time will tell. This has been an expensive trial. Next effort will be to recover the cost of the unnecessary ignition switch replacement.
  20. Thanks for the tips. I'll be in a better position when I approach the dealer for the correct fix- and will report on the outcome.
  21. I need the combined wisdom of the team for this one. 2001 STS . Recurring pattern: turn the key, no sound, nothing. Lights work O.K. After waiting anywhere from 15 minutes to an hour or more it starts and runs fine. No codes. Caddy dealer says if it happens while they can observe it they can diagnose the problem. It happens again. I have the car towed to the dealer, they keep it all day - and of course it starts fine - every time. No codes , and supposedly the scan tool didn't provide any clues. The Delco battery is 3 years old but checked O.K. (according to the mechanic.) Dealer suggests the probable cause is a faulty ignition switch - $300. Not being in the mood for diagnosing the problem by the parts replacement method, I decline and drive away. When the problem manifests itself again in a couple weeks, I had found my spare key, and voila, it started right up. I’m feeling good. But then the no start pattern appears again a couple of more times – each time starting fine after it sits for a few minutes. I’m thinking that maybe the security pill inside the key might be breaking down. I buy a new key, and for a couple weeks all is well. But the no start problem sporadically reoccurs. I take the car to the Caddy dealer…. This time while they have it the no start condition does occur. Now I’m thinking, this will finally yield an answer. Dealer suggests again that it is the ignition switch, and I open my wallet and remove $300, consoling myself that that at least this will put an end to my misery. Wrong again. I drive it home - and a few hours later - no start / no crank . This one has really been a test. Any help or comments from the esteemed membership would be greatly appreciated.
  22. Success! I finally broke down and bought an OEM ballast ($ 262.00) and wiring harness ($ 18.00) from GMPartsdirect. Headlight working fine now. The D1S systems on Cadillacs have a mind of their own, and for some reason after market ballasts don't seem to work reliably on that system. ( bulbs work fine) I found that out after much trial and error. Rusty
  23. That's not a bad idea. I have an extra lamp from the replacement set I bought . I returned it because the mechanic said it didn't work. Vendor said otherwise. This time I'll install it. Regards, Rusty
  24. In the event you don't have the wiring drawing for your headlamps I've included it. You can see both headlamps are powered by the same set of contacts on the Low Beam Headlamp Relay. I think that rules out the relay as a cause of your problem since it is isolated to the right headlamp only. Similarly, the relay doesn't much care whether it is activated by manual or automatic control. Is it possible it was just a "fluke" your right headlamp activated when you switched to manual on/off? I'd be looking for a wiring difficulty. You mentioned you had to replace the fuse for the right front headlamp. Fuses blow for two reasons: 1] Excess current was drawn due to a short circuit (pinched wire etc.). 2] A high resistance connection at the fuse itself caused enough heat to be generated to melt the fuse in the absence of a short circuit. If the contacts/wiring at the fuse block are "solid," I'd be inclined to look for a pinched/open wire. Regards, Warren Thanks for the reply. I appreciate the schematic and agree with your reasoning . I haven't really seen a predictable pattern yet. Last night I started it up and after the RH light failure tried to use the manual setting - and the RH light still didn't fire up. Second startup worked fine - on the auto sensor setting, as have 3-4 additional times I fired them up, on auto and manual. It may take a little longer to pin down, but I think the cause is getting narrowed a bit. Thanks, again.
×
×
  • Create New...