Jump to content

fivepointohman

Registered
  • Posts

    195
  • Joined

  • Last visited

Previous Fields

  • Car Model and Year
    1996 seville

fivepointohman's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Looking for a abs module harness and block for a 1996 cadillac seville SLS or STS... Even an entire engine harness.... I need to save a really nice 96 and can't seem to find the harness... any info would be great... my email is fivepointohman@hotmail.com
  2. I did replace it with a remanufactured pump... I cleaned the pulleys clean of oil and installed a new belt. I will R&R with a new pump then this weekend.
  3. I replaced my pump today due to a bad bearing in the pump on my 96 seville sls.. After I replaced it with a new unit, the steering was completly gone.. I would rev up the motor and it would get better, at idle nothing... After turning the wheel back and forth for hours, and driving it with some WOT, it compeletly lost power steering.. Could I have damaged the rack or could it just be a bad pump? I am completly out of ideas.. before the pump replacement steering was completly normal and free...
  4. I need an ABS pump / module wiring harness for a 1996 seville sls or sts and i believe a 1996 deville works too... Any help would be great! Thanks.
  5. Agreed it's everyones opinion..... I have bypassed the heater hoses on both my cadillac and my mercedes and have had no issues ever with better results in performance than before... So It's a matter of opinion.... No big deal...
  6. The coolant bypass is there to act as a choke, like in our older carburated cars. It heats the incoming air when it it cold out... Since I drive my car only in the summer i dont need to heat the in coming air, plus hot air means less power and detination... So it is a plus... some also say it is used to looses deposits in the throttle body, I clean mine constantly so it's not an issue. Yea I have to take a photo of it completely on there... All the components were cleaned at the shop with a acid dip, but I painted them all up afterwards... the intake gaskets were beyond worthless, the gasket material was lower then the surrounding framework of the gasket itself so meaning there was no gasket... they car ran strong anyways, but outside dirt oil and debris sealed up the runners.
  7. Also, I love the fact that with the coolant bypass modification done to the throttle body you can actually touch the throttle body when the engine is hot and the incoming charge of air is nice and cool and not super heated...
  8. Agreed.... that hydro lock is exactly why i didnt clean it on the car etc... I had it dipped and heat treated at the shop and left it off for a week, so it was perfectly dry.... I am happy with the job.... Here are some pics! http://c2.ac-images.myspacecdn.com/images0...3041a95e651.jpg
  9. Cool welcome aboard, introduce yourself, what do you do for a living? I am sorry for the delay on reporting back on the head gasket leak issue on the 2000 northstar engine at 71000 miles. I replaced the water pump cover gasket, changed the Dex Cool and added 3 GM cooling system seal tabs to cooling system. The engine now has another 1000 miles on it with no visible coolant leaks or weeping from the head gasket. I also replaced the temp sensor to the left of the steering column behind the small grill that has the small fan that was making the noise when cold. I used Cadillac parts. Thanks again for all of your input. I am a retired mechanical eng. and have had a life long auto hobby. Is that temp sensor on the back of the head near the firewall under the EGR valve?
  10. Cool welcome aboard, introduce yourself, what do you do for a living? I am sorry for the delay on reporting back on the head gasket leak issue on the 2000 northstar engine at 71000 miles. I replaced the water pump cover gasket, changed the Dex Cool and added 3 GM cooling system seal tabs to cooling system. The engine now has another 1000 miles on it with no visible coolant leaks or weeping from the head gasket. I also replaced the temp sensor to the left of the steering column behind the small grill that has the small fan that was making the noise when cold. I used Cadillac parts. Thanks again for all of your input. I am a retired mechanical eng. and have had a life long auto hobby. Is that temp sensor on the back of the head near the firewall under the EGR valve?
  11. So I went ahead and took my manifold off to clean out the ever so discusting carbon and oil biuld up... it was amazing, my map sensor port was almost totally sealed, along with the FPR port.... The gaskets were leaking incredibly as I saw a trail of carbon and fuel leaking around the seals and into the valley. So needless to say 80 dollars later I had the the entire intake throttle body and EGR spacer completly acid dipped and blasted... Looks amazing now and oh so clean! put it together with all new gaskets and car fired up strong and throttle response is amazing! Now here is the info I was told at my local engine dino and biulder... He asked what fuel octane i was using.. I was using 93... He told me that was alot of the cause as to why it got this nasty... the 93 doesnt burn quick enough and thus we have loads of deposits. he recommends 89 max and even 87 for cleanest operation and performance. he states 93 looses HP. I played devils avocate with the whole knocking issues and valve damage from low octane , he said not a issue the ecm will adjust timing as needed... he also says my CAT is probably completly clogged with deposits as my intake was. makes sense as my exhaust smells as though there is no converter.. NO codes however... Either way a high flow cat was ordered weeks ago so it's not really an issue.. my intake valves looks spotless with literally no deposits... I wonder about the exhaust side... So what does everyone think of this?
  12. Will do.... I take it your just living with it for now and or did the fluid change resolve it?
  13. Quick question? is there a shiftt solenoid for reverse... The car before i stored it for the winter started to have a delay in reverse engaugement.... the drive solenoids have been replaced. no codes. trans has 129K original.
  14. So I seem to have developed a new problem with my 96 sls as my car has been sitting for the winter months. my headlights wont come on... when I put the car in drive the day time lights wont come on, and when I turn them on manually everything but the headlights come on, the highbeams switch on and off fine... checked the relay and fuse all ok... Along with that suddenly the battery has been dieing. what could be the cause of this?
×
×
  • Create New...